• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FS2004 How to solve little issues in AFLT 3.5

Messages
1,414
Country
germany
If you use AFLT for an easy and perfect way to create 3D airport and approach lighting mostly you begin with ADE9 to define runway, taxiway and approach lighting.

The you use AFLT to create the nice 3D objects and purge the lights in your ADE9 BGL.

All looks fine:

LRTM4.jpg


But on a closer look you will see some small issues:

LRTM5.jpg


There are missing 3D objects (poles, bars or light heads) and strange lights instead.

LRTM6.jpg


What now?
I used this way:
I loaded the airport from "stock" in ADE and "saved as" with a different name.
Now I imported in this ADE the file from AFLT "AFLT_LRTM_Bases_9.bgl" and got this picture:


LRTM7.jpg


ADE9 did not know thes objects, so I had to use the ADE TOOL "Library Object Manager" to "ADD Folder" and save it. (I had to ignore some errors, because these GUIDs were already imported)
But then I could see the problems:
LRTM9.jpg


LRTM10.jpg

There were lights instead of bases!

To get coordinates and GUIDs was easy. Click on the wrong object to make it "active" and "right click" to show the XML code.


LRTM11.jpg


So I stored these XML codes of wrong objects and fine objects in a TXT file for later use.

Now I could use BGL2XML for "AFLT_LRTM_Bases_9.bgl" to get the XML Code.
Searching the wrong objects with my "lat=..........." from the TXT file was easy and replacing the GUID no problem.

Finally Xml2Bgl creates the correct "AFLT_LRTM_Bases_9.bgl"

I have no idea if the issue is in FSX, P3D also visible and would be glad if this was clear enough for the developer community-
 

tgibson

Resource contributor
Messages
10,733
Country
us-california
Hi,

I have seen some of the errors you mention, so I believe they are bugs in the program. Unfortunately the author has passed away and there will be no more updates. You will need to use it as is.
 
Messages
1,414
Country
germany
Yes Tom, I know.
Arno and Jon have no source.
I wanted to show a way to correct these little bugs.

Sorry, if I was not clear enough
 

tgibson

Resource contributor
Messages
10,733
Country
us-california
Glad your approach worked, because that will be (at least) one way to fix these problems.
 
Top