P3D v4 I Don't Get It

#1
I'm back again with the same problem I started having with FSX before I kicked it to the curb. Now I've had my computer completely revamped: new mother board, new solid state drive, new processor, new program (Prepar3d v4). My version of ADE is 1.76.6715 and, just like before, when I compile, no changes are made to P3D. I get no compiler error messages and when both programs are running I can see the little "x" in ADE marking the aircraft that I'm using slewing around the airport. My guess is that it's compiling to the wrong folder. Currently that's: C:\Program Files\Lockheed Martin\Prepar3d v4 SDK 4.3.29.25520\World\Scenery. This was the path chosen for me by the ADE new user wizard. I've also tried other paths with either the same result or a message telling me it can't compile to that folder. Anyone have an idea to what I'm doing wrong? Thanx.
 
Last edited:
#2
Have you tried Compiling to your Desktop?
perhaps your anti-virus (if you have one) is stopping it going somewhere you wish
when i had a similar issue it worked compiling to the Desktop then i can drag/drop it where i like, as i don't always want to overwrite the file in the Addon Scenery\scenery folder
been doing that for years now, so now i know exactly where it is every time i compile
 
Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#3
I am not sure how ADE would give you that folder. I don't think that is a valid folder. You can check exactly where it is compiling by checking the compile options when you click Compile

1539332145562.png


And you can change that for the project by clicking More Options:

1539332200284.png


You can set the defaults which apply to any new project by choosing Settings > Options > Project:

1539332302929.png


Ray's point is a very good one. If you are trying to compile into C:\Program Files\... then chances are that User Access Control (UAC) will stop you. The compiler can't tell you (it is not that bright) but the file won't be saved if you are trying to send it to a UAC controlled folder. We strongly recommend that any Sim is not installed in the default c:\Program Files\ or c:\Program Files (x86) folders since these are protected and getting files saved there can be very unpredictable.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#4
And it's a bad idea to place files in the world folder with default files anyway. You better put your modifications in an addon scenery folder to separate them from default files.
 
#5
Thanks for all of the replies gentlemen. I tried compiling to the desktop and, from there, placed a copy everywhere I saw other bgl files and (some places there weren't). Some of these places required administrator permissions, which I did, and still no go. Before doing that, I also temporarily disabled my anti-virus program in case that would work; it didn't. I also deleted and re-downloaded ADE to get back all of the default paths since, at this point, I don't know what all I may have changed. Obviously I must have changed the path somewhere along the way because I got the same paths back that Jon sent in his reply . Despite all of this I still get the same results. I'll keep fiddling with it and if I find out what's wrong I'll report back. Thanks again guys,

Eric
 
Top