I?m going crazy with SB

#1
Hi folks,
I'm trying to work with SB but I'm going nowhere with it.
I started a new project from scratch, imported a map, calibrated it, choosed the photo, ground and water tiles but I can't compile, all options in the compile window are disabled but the compile button.
In the attachments you can see the project preferences, an overview of the map with checked tiles and the compile window.
SB version is 2.04, SCASM version is 2.96 and installed in the SB's Tools folder.

Any suggestion?

Thanks in advance
Alessandro
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi Alessandro,

Did you first select the objects you want to export? Without selecting them no options are available on the export screen.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#4
Hi Alessandro,

When you have add the photos tiles for the area you want them, just select them all before you go to compile BGL.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#6
If you have multiple object, it is easiest to just use select and drag around your entire scene.
 
#8
Just a little step ahead. I made a photo scenery with only photo tiles, no water, land or objects.
SB made the bgl and bitmap files and I put all in AddonScenery\test\scenery and texture.
But, in FS9, when I open the area covered by the scenery, FS exits itself without messages.

This is my face and mood: :confused:

Any suggestion?

Tks
Alessandro
 

bpahe

Resource contributor
#9
Hi!

Make sure that you try the scenery in the same season that you created the bitmaps for, i.e. if you only exported summer bitmaps, FS will crash if you do not load the scenery during summertime.
A less likely cause to failure is that the bitmaps are placed in the /texture forlder. You can try to place them in FS/Scenery/World/Texture if the problem persists.

/hans
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#10
bpahe said:
A less likely cause to failure is that the bitmaps are placed in the /texture forlder. You can try to place them in FS/Scenery/World/Texture if the problem persists.
Actually this is the only reason of the crash. When placing photo tiles with VTP polygons, the texture MUST be in the world/texture folder. If they are not found there, FS will crash.
 

bpahe

Resource contributor
#11
Sorry, my mistake. It have been a couple of months since I last placed phototiles, and I made the same mistake. Ignore my prior posting.

/hans :eek:
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#12
I can tell you that I made the same mistake as well. I even reported it to Luis, while the manual clearly says you should place them in the world/texture folder :).
 
#13
Yes, it works!!!
Now the last thing: my photo tiles include a coastline: when I see the area in FS the original coastline is visible, even if I make a flatten (altitude 0 or above) or exclude areas. Could the solution be to make mesh tiles?

PS: my scenery is at level 1 in the scenery list of FS.

Cheers
Alessandro
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#14
Hi Alessandro,

If you make a VTP exclude for the layer of the default coastlines, you should be able to remove them.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#16
I can't remember those layers myself, but SBuilder tells you the default layers when you make an exlcude. The coastlines are layer 8.
 
Top