• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Invalid Tag error for every KML

Hi everybody,

I made some KML Files for my area, fixed them with PreFSX and try to build the scenery with FSXKML110. Unfortunately each of my tries ends very fast with "Invalid tag in [tagname]" (for each and every polygon).

Two major questions came up:
  • Can I somehow find out which tag exactly is invalid? It seems that, despite strictly following the manual, I make any general mistake when producing the KML files...
  • Will I still need to "tidy" every KML file with preFSX or is that functionality implemented meanwhile? Or did I probably destroy working KML files by using an outdated tool on them?
  • I'm insecure about the FWTools path (didn't find detailed info on that). Will I have to set the path in FSXKML as the \bin subdirectory (where all the *.bat files are)? Or will I have to set the environment variables as they recommend?
Thank you for consideration,
Regards
Mick
 
I got the problem solved myself. The invalid tag error was my own fault (in the end a typo which I had overlooked several times).

For others: I didn't have to use the PreFSX-Tool on the KML-file, and the FWTools path worked in both ways (with and without the "\bin" subdirectory at the end of the path).
 
Hello:

If Google Earth was used for your KML/KMZ vector source data (ex: poly-lines / polygons), which numeric version of Google Earth was it ? :scratchch

GaryGB
 
Hi Gary,

I use(d) Google Earth Version 7.1.2.2041 (Build date 10/7/2013), and – apart from my own bs – everything worked very well and easy.
Take care that you tag the polygons properly (using the taglist inside FSXKML is fine and simple to do), then it should be a cakewalk.

Regards
Mick
 

mendiola_loyola

Resource contributor
FSX_KML works with google Earth Version 5.x. You can patch your kml file, but it is a hand work that would take a lot of time if your kml has a lot of coordinate tags.

Regards.
Alfredo Mendiola Loyola
Lima, Peru
 
You can patch your kml file, but it is a hand work

Not necessarily. If you're using a later version of Google Earth, you can use this tool http://www.fsdeveloper.com/forum/resources/prefsxkml.82/
to patch the files with a few clicks. The tool has to be run as administrator, because it sets 2 keys in the registry.

But, like I said before, there are many files that I don't need to use the tool. The error was my own typo.

Enjoy :wave:
Mick
 
Last edited:
Top