P3D v4 IVAO MTL add-on xml code for P3D v4

#1
Hi,

Recently BVAI model matching by Boston Virtual ARTCC for VATSIM was released (in beta). The process of the installation is pretty easy and simple. It works perfectly in the simulator. You may find more info from their forum here. You may download it from here.

So, I was trying to do is the similar thing for IVAO MTL. As we know, for IVAO MTL we need to add entry into the simobjects.cfg located at C:\ProgramData\Lockheed Martin\Prepar3D v4. I was trying to avoid this step. So I copied the addon xml from BVAI and changed the info as follows:

BVAI Add-on:
Source path - C:\Users\[YOUR COMPUTER]\Documents\Prepar3D v4 Add-ons\BVAI
XML:
<SimBase.Document Type="AddOnXml" version="4,4" id="add-on">
  <AddOn.Name>BVAI</AddOn.Name>
  <AddOn.Description>BVAI - Next Generation Model Matching</AddOn.Description>
  <AddOn.Component>
    <Category>SimObjects</Category>
    <Path>F:\Flight Simulators\Addon\Traffic\BVAI (MTL for VATSIM)\SimObjects\Airplanes</Path>
  </AddOn.Component>
  <AddOn.Component>
    <Category>Effects</Category>
    <Path>F:\Flight Simulators\Addon\Traffic\BVAI (MTL for VATSIM)\Effects</Path>
  </AddOn.Component>
  <AddOn.Component>
    <Category>Texture</Category>
    <Path>F:\Flight Simulators\Addon\Traffic\BVAI (MTL for VATSIM)\Texture</Path>
  </AddOn.Component>
</SimBase.Document>
to something like this:

IVAO MTL Add-on:
XML:
<SimBase.Document Type="AddOnXml" version="4,4" id="add-on">
    <AddOn.Name>IVAO MTL</AddOn.Name>
    <AddOn.Description>IVAO MTL Models for P3D v4</AddOn.Description>
    <AddOn.Component>
        <Name>IVAO MTL</Name>
        <Category>SimObjects</Category>
        <Required>True</Required>
        <Active>True</Active>
        <Path>D:\Lockheed Martin\Prepar3D v4\SimObjects\IVAO_MTL</Path>#<<<You may change this path according to your IVAO MTL location path
    </AddOn.Component>
</SimBase.Document>
Unfortunately, the model doesn't show in the simulator. Any idea how to make it work?
 
Last edited:
#3
Found some info about this issue from http://forum.ivao.aero/index.php?topic=318023.0:
This is a bug in the updater for v4 which doesn't write the proper entries to simobjects.cfg on fresh installs. A fix should be available tomorrow.

Meanwhile, you can add the following section to your C:\ProgramData\Lockheed Martin\Prepar3D v4\simobjects.cfg file, where Entry.x is to be modified with the next number in list in your file (i.e. Entry.6 if the last is Entry.5):

Code:
[Entry.x]
Title=IVAO_MTL
Path=SimObjects\IVAO_MTL
Required=True
Active=True
There are few known issues in the updates like model black without texture, no landing gears on the models, invisible models and etc.

*You will not need to enter the above entry if you assign add-on.xml as below:
IVAO MTL Add-on:
XML:
<SimBase.Document Type="AddOnXml" version="4,4" id="add-on">
    <AddOn.Name>IVAO MTL</AddOn.Name>
    <AddOn.Description>IVAO MTL Models for P3D v4</AddOn.Description>
    <AddOn.Component>
        <Name>IVAO MTL</Name>
        <Category>SimObjects</Category>
        <Required>True</Required>
        <Active>True</Active>
        <Path>D:\Lockheed Martin\Prepar3D v4\SimObjects\IVAO_MTL</Path>#<<<You may change this path according to your IVAO MTL location path
    </AddOn.Component>
</SimBase.Document>
 
Last edited:
Top