FSXA I've Tried Everything…(new mission category)

#1
…well obviously I haven't tried everything because I cannot get it to work–I cannot create a new mission category :banghead:

I followed the Tutorial in the SDK guide. I noted the errors in the example file and corrected them. I downloaded and used the MS GUID creator. I did everything by the book. Nothing worked.

Time to search the FSDeveloper Forums. I quickly discovered http://www.fsdeveloper.com/forum/posts/126643/ which describes the exact same problem - a great thread.

I read it to the end, found all the little nuances that were left out of the SDK guide and (drum roll) still nothing!

The mission itself shows up just fine under "All Categories". But the Mission Category it self does not.

I've played with the UFT-8, UFT-16 and Unicode settings…nothing!

Here are the Category File and Mission File from my latest attempt:

-------------------------CATEGORY FILE-------------
<?xml version="1.0" encoding="UTF-16"?>
<SimBase.Document Type="AceXML" version="1,0" id="PGCatagory">
<Descr>AceXML Document</Descr>
<Filename>PGCatagory.xml</Filename>
<SimMissionUI.ScenarioCategory id="{D91E1CD5-60DF-44bf-A221-6E3CB4A9F1B9}">
<Descr>Fly Well</Descr>
<Title>Ghost Flights</Title>
<PreviewImage>PG_Header_256.bmp</PreviewImage>
</SimMissionUI.ScenarioCategory>
</SimBase.Document>


------------------------MISSION FILE----------------
<?xml version="1.0" encoding="UTF-8"?>

<SimBase.Document Type="MissionFile" version="1,0">
<Title>Ghost Flight 1</Title>
<WorldBase.Flight>
<SimMissionUI.ScenarioMetadata InstanceId="{D91E1CD5-60DF-44bf-A221-6E3CB4A9F1B9}">
<Descr>Ghost Flights</Descr>
<ScenarioType>Mission</ScenarioType>
<SkillLevel>Advanced</SkillLevel>
<LocationDescr>Switzerland</LocationDescr>
<EstimatedTime>30 Minutes</EstimatedTime>
<UncompletedImage>PG_M1_Graphic.bmp</UncompletedImage>
<CompletedImage>PG_M1_Graphic_Done.bmp</CompletedImage>
<MissionBrief>Ghost_M1_Brief.HTML</MissionBrief>
</SimMissionUI.ScenarioMetadata>
</WorldBase.Flight>
<MissionBuilder.MissionBuilder>
</MissionBuilder.MissionBuilder>
</SimBase.Document>


Thoughts? (Yes, I know I misspelled "Catagory" in the Category file but I spelled the file name the same way - it's all exactly the same…misspelled but the same.) :cool:
 
#2
Hi Folks

Will -
You'd populated/edited a proscribed field.

Following should work, (not tested).

Code:
<?xml version="1.0" encoding="UTF-16"?>
<SimBase.Document
        Type="AceXML"
        version="1,0"
        id="FSCategories">
    <Descr>AceXML Document</Descr>
    <Filename>PGCatagory.xml</Filename>
    <SimMissionUI.ScenarioCategory id="{D91E1CD5-60DF-44bf-A221-6E3CB4A9F1B9}">
        <Descr>Fly Well</Descr>
        <Title>Ghost Flights</Title>
        <PreviewImage>PG_Header_256.bmp</PreviewImage>
    </SimMissionUI.ScenarioCategory>
</SimBase.Document>
HTH
ATB
Paul
 
Last edited:
#3
I assume you mean
id="FSCategories">

If so, roger that - understand. Plus a glance at the FSXXCategories.xml file shows that field just as you described it. One would think if that field needed to be the same as the file name, it would have been that way in FSXXCategories.xml–it isn't.

However, in about the first dozen or so tries I had that field precisely as you have it above and it still didn't work. Then I saw this from the thread that I mentioned above:

I found that you have to change the id="FSCategories" like it is shown at the bottom, in the new file you create for your category.

Works fine for me.

<SimBase.Document Type="AceXML" version="1,0" id="FSCategories">

<SimBase.Document Type="AceXML" version="1,0" id="you category file name here">

Jean-Guy
YugNaej, 14/4/10
Which is why I changed it.

Now comes the weird part. I decided to just let it alone for a while while I worked on other parts. I also wanted to try FSX Mission Editor having just downloaded the free demo. I worked a bit and then tested the mission to completion. I fiddled with it some more and while doing so, I noticed my category showing in the SimMissionUI.ScenarioMetadata Attributes dialog menu/box. Strange, so I shut FSX ME down, started up FSX and there was my new category in the list!

What the heck? I didn't do anything.:confused:

The only thing I added was a Mission Brief HTML that FSX finally could read. I never changed the proscribed field.

I think I'm going to "let sleeping dogs lay" for right now. That said, thank you very much for your advice and taking time to answer this question - I truly appreciate it and quite frankly I think it is absolutely correct…I really have no clue as to why it is now working. Once I get a few things wrapped up I'll go back and see if I can figure out what was going on.

Thanks again!

ATB
Will
 
Top