• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Landing gear issues

Hey everyone.
Working on the landing gear inside of Blender for MSFS2020.

The l_gear and r_gear are keyframed and working great. They are retracting and lowering, with compression.
Keyframe up at 0, lowered at 100 and full compression at 200.

I have done the same with the c_gear but it doesn't do anything.

All the xml is the same just can't figure this out
This is the point where you do some basic debugging to determine what the problem is.

First step, use SimvarWatcher to check the values of the A: vars for the landing gear are actually changing.

Check the the animation name of the Blender NLA track exactly matches the name of your animation.

Swap the names of the animations in Blender with the l_gear. If the front gear works with the l_gear name and the left gear stops working with the c_gear name then you know your Blender animations are fine, but your XML is wrong.

Are you using old style animation code? One with GUID numbers? Change the GUID number. Double check your syntax. Or completely overwrite your c_gear code with l_gear code and make the necessary changes.
I tried swapping the names in Blender and all the gear worked.

I couldn't see any errors in the XML but I re-wrote the XML and that got it working.

Thanks for the help.
well it is still having problems.
all the other anim work.
Just anything with the C-gear or c_tire_anim dont.

it is keyframed correctly as I can change it to L_gear or r_gear and the gear works.

here is my xml for the gear

<UseTemplate Name="ASOBO_GEAR_Center_Template">
<UseTemplate Name="ASOBO_GEAR_Center_Tire_Template"> <ANIM_NAME>c_tire_anim</ANIM_NAME> <NODE_ID_STILL>WHEEL_STILL_center</NODE_ID_STILL>
<UseTemplate Name="ASOBO_GEAR_Left_Template">
<UseTemplate Name="ASOBO_GEAR_Right_Template">
<UseTemplate Name="ASOBO_GEAR_Left_Tire_Template">
<UseTemplate Name="ASOBO_GEAR_Right_Tire_Template">
<UseTemplate Name="ASOBO_GEAR_Steering_Template">

I have copied and changed this a million times and can't get the c_gear to work

all other planes that are in the game are not having problems

any ideas?
Last edited: