• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSXA Large areas flattened outside some airports

Messages
1
Country
finland
I've recently started using Terrain Sculptor to blend scenery with accurate mesh, and generally it's working almost perfectly (the triangulation function considers non-flatten type polys as well which means having to remove for example ExcludeAutogen polys before triangulation but that's a minor annoyance). A couple of airports are producing large flattened areas well outside the airport area however. After triangulation everything looks great, but when creating the CVX file and looking at the result in FSX it's clear that something went wrong. Opening the created CVX file in Terrain Sculptor shows the unexpected flattened areas as well.

I also downloaded Terrain Sculptor Pro to see if it did the same. It doesn't seem to mind the non-flatten polys when triangulating which is nice, but I'm unable to create the CVX file with it. When clicking the Export to FSX/P3D menu item after triangulation, the memory usage of the program just starts to increase until it throws an out of memory error. This is on a Windows 10 64bit system with, as far as I can tell, all the latest updates to the operating system and the .NET framework installed.

efro1.jpgefro2.jpg
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
TS and TS Pro and totally different program intended to accomplish similar functions. I'm glad that TS Pro solved one of your difficulties.

I am in the process of expanding TS Pro to handle additional terrain types and seem to have inadvertently affected the .bgl file generation code. It may take me a few days to sort it all out and to be able to fix the "memory loop" issue you are experiencing. In the meantime, to ensure I've really fixed the issue, it would help if you sent me associated the .TSD and .TSP files and your TS Pro.ini file. You can send them to me via e-mail at don at stuff4fs dot com.

As an interim measure, it may be faster to fix TS (which is ro be phased out eventually in favor of TS Pro). In either case, having your files may be helpful.

Don
 
Messages
606
Country
germany
Hi Don, sorry for stepping in here, but when reading about problems with creating CVX files I felt justified doing this as I opened the forum for reporting such problems.

About two months ago I changed from W7Pro to the corresponding Win 10 version. I can't say it's a fresh install because of FSXA and diverse other apps are installed meanwhile. However, I can say it's well maintained.

When using TS v. 1.2.08 (c) everything looks smooth until it comes to the point exporting the data to a CVX BGL file. There is no error report at all, a windows appears during the process reporting that it writes vector data to cvxshapes, done for 161 shapes. Unfortunately the result doesn't change anything and when looking closer to the produced file it appears to have no useful date included as it's size is just 56 Bytes.

Now TS Pro comes in the game:
When starting it, the app claims an unknown file type (of course it doesn't tell anything more), but loads without running into further obvious problems.

1518884721188.png

I was able to load the project, but got an error message when running the "Profile outline" function when using the default parameters (I know similar events with elder versions, too). Indeed, it completed when changing the elevation parameter from 5% to 10%. This wasn't reproducible, however. Unfortunately the final result was the same as last time (the same 56 Bytes) as the elder version.

The respective massage while processing the file is here (almost the same as above already mentioned):

1518885942756.jpg

However, TS Pro tickles me with some other problems, too:

Trying to start it before FSX is running, it produces an exception error message (it survives nontheless the 'Ignore' button).
When leaving the FS in order to look for the results, it starts producing exception errors.

First comes a .NET error...
- <System>
<Provider Name=".NET Runtime" />
<EventID Qualifiers="0">1026</EventID>
<Level>2</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2018-02-17T14:45:37.857806000Z" />
<EventRecordID>11998</EventRecordID>
<Channel>Application</Channel>
<Computer>xxxxx</Computer>
<Security />
</System>
- <EventData>
<Data>Anwendung: TS Pro.exe Frameworkversion: v4.0.30319 Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet. Ausnahmeinformationen: System.ArgumentException bei System.Drawing.Bitmap..ctor(Int32, Int32, System.Drawing.Imaging.PixelFormat) bei System.Drawing.Bitmap..ctor(Int32, Int32) bei Terrain_Sculptor_Pro.DisplayData.DrawData() bei Terrain_Sculptor_Pro.DisplayData.UpdateDisplay() bei Terrain_Sculptor_Pro.MainPanel.LostConnection() bei Terrain_Sculptor_Pro.Communications.CloseConnection(System.String) bei Terrain_Sculptor_Pro.MainPanel.Form_Closing(System.Object, System.Windows.Forms.FormClosingEventArgs) bei System.Windows.Forms.Form.OnFormClosing(System.Windows.Forms.FormClosingEventArgs) bei System.Windows.Forms.Form.RaiseFormClosingOnAppExit() bei System.Windows.Forms.Application.ExitInternal() bei System.Windows.Forms.Application+ThreadContext.OnThreadException(System.Exception) bei System.Windows.Forms.Control.WndProcException(System.Exception) bei System.Windows.Forms.Control+ControlNativeWindow.OnThreadException(System.Exception) bei System.Windows.Forms.NativeWindow.Callback(IntPtr, Int32, IntPtr, IntPtr) bei System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG ByRef) bei System.Windows.Forms.Application+ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr, Int32, Int32) bei System.Windows.Forms.Application+ThreadContext.RunMessageLoopInner(Int32, System.Windows.Forms.ApplicationContext) bei System.Windows.Forms.Application+ThreadContext.RunMessageLoop(Int32, System.Windows.Forms.ApplicationContext) bei Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun() bei Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel() bei Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(System.String[]) bei Terrain_Sculptor_Pro.My.MyApplication.Main(System.String[])</Data>
</EventData>
</Event>

...followed by an Application Error
- <System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2018-02-17T14:45:38.095786900Z" />
<EventRecordID>11999</EventRecordID>
<Channel>Application</Channel>
<Computer>xxxxx</Computer>
<Security />
</System>
- <EventData>
<Data>TS Pro.exe</Data>
<Data>0.0.0.1</Data>
<Data>59ff9eae</Data>
<Data>KERNELBASE.dll</Data>
<Data>10.0.16299.15</Data>
<Data>2cd1ce3d</Data>
<Data>e0434352</Data>
<Data>001008b2</Data>
<Data>1378</Data>
<Data>01d3a7fdbdcefcad</Data>
<Data>D:\Flightsims\FS Design Tools\Terrain Scupltor PRO\TS Pro.exe</Data>
<Data>C:\Windows\System32\KERNELBASE.dll</Data>
<Data>9f2583d5-4775-4f53-a4db-0b4c9c698e27</Data>
<Data />
<Data />
</EventData>
</Event>

The latter will repeat after almost 2 Minutes when leaving TS Pro running.

Fanally no error, but a wish: When using the Pro version, the imported flatten nodes are yellow and hardly visible on a white background. Having an option to change colours would be nice.
 
Last edited:

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
When using TS v. 1.2.08 (c) everything looks smooth until it comes to the point exporting the data to a CVX BGL file. There is no error report at all, a windows appears during the process reporting that it writes vector data to cvxshapes, done for 161 shapes. Unfortunately the result doesn't change anything and when looking closer to the produced file it appears to have no useful date included as it's size is just 56 Bytes.
As noted above, TS is "dead" or soon will be - in favor of TS Pro.

When starting it, the app claims an unknown file type (of course it doesn't tell anything more),
Not sure what more can be included. The user knows the filetype of the selected file. If you believe it to be a filetype TS Pro should handle, please post the file so I can test.

First comes a .NET error...
...followed by an Application Error
I've never seen either of these messages before - ever. But, I will attempt to repeat the described process.

the imported flatten nodes are yellow and hardly visible on a white background. Having an option to change colours would be nice
TS Pro defaults to the color specified for the terrain type in the terrain.cfg file. If you don't like the color, you can change it from the right-click menu.

Thanks for reporting these issues.

Don
 
Messages
606
Country
germany
Not sure what more can be included. The user knows the filetype of the selected file. If you believe it to be a filetype TS Pro should handle, please post the file so I can test.
There was nothing open before, but a self produced file. (.tsd). I've looked into the TS Pro.ini and saw the saved BGL appearing as "Path to Last Project=" which is true. Nonetheless the message appears after changing this entry pointing to the original TSD. The app loads anyway - despite the message.

TS Pro defaults to the color specified for the terrain type in the terrain.cfg file. If you don't like the color, you can change it from the right-click menu.
Probably I'm too stupid using this function. I selected first just node of the flatten, but it didn't work. Then I selected all nodes, tried to select a new colour and ended up with an exception message. I'm going to boot my PC again an if anything changes, I'll come back...
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
There was nothing open before, but a self produced file. (.tsd). I've looked into the TS Pro.ini and saw the saved BGL appearing as "Path to Last Project=" which is true.
That should be easy to fix. But, since it didn't compile properly, it would be helpful to have the file.

I selected first just node of the flatten, but it didn't work.
Worked for me, (but I'm using a version with a few fixes.

Then I selected all nodes, tried to select a new colour and ended up with an exception
Me. too. Leave it with me. I plan to make a new development release in the next few days and I'll address these issues.

Don
 
Messages
606
Country
germany
Here I am again...
Nothing changed, but the last exception error had been caused by the missing FSX that wasn't loaded before booting TS Pro.

1518891277039.png


The details are here:

************** Ausnahmetext **************
System.ArgumentException: Ungültiger Parameter.
bei System.Drawing.Bitmap..ctor(Int32 width, Int32 height, PixelFormat format)
bei System.Drawing.Bitmap..ctor(Int32 width, Int32 height)
bei Terrain_Sculptor_Pro.DisplayData.CreateBaseImage()
bei Terrain_Sculptor_Pro.DisplayData.CalcScalingFactors(Double kZoom, Boolean bCalcScroll)xxxx
bei Terrain_Sculptor_Pro.DisplayData.Init_DataView(Boolean bRecalc)
bei Terrain_Sculptor_Pro.MainPanel.FormResized(Object sender, EventArgs e)
bei System.Windows.Forms.Control.OnResize(EventArgs e)
bei System.Windows.Forms.Form.OnResize(EventArgs e)
bei System.Windows.Forms.Control.OnSizeChanged(EventArgs e)
bei System.Windows.Forms.Control.UpdateBounds(Int32 x, Int32 y, Int32 width, Int32 height, Int32 clientWidth, Int32 clientHeight)
bei System.Windows.Forms.Control.UpdateBounds()
bei System.Windows.Forms.Control.WndProc(Message& m)
bei System.Windows.Forms.ScrollableControl.WndProc(Message& m)
bei System.Windows.Forms.Form.WndProc(Message& m)
bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Geladene Assemblys **************
mscorlib
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2600.0 built by: NET471REL1LAST.
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll.
----------------------------------------
TS Pro
Assembly-Version: 0.0.0.1.
Win32-Version: 0.0.0.1.
CodeBase: file:///D:/Flightsims/FS%20Design%20Tools/Terrain%20Scupltor%20PRO/TS%20Pro.exe.
----------------------------------------
Microsoft.VisualBasic
Assembly-Version: 10.0.0.0.
Win32-Version: 14.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll.
----------------------------------------
System
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll.
----------------------------------------
System.Core
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2600.0 built by: NET471REL1LAST.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll.
----------------------------------------
System.Windows.Forms
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll.
----------------------------------------
System.Drawing
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll.
----------------------------------------
System.Configuration
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll.
----------------------------------------
System.Xml
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2612.0 built by: NET471REL1LAST_B.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.
----------------------------------------
System.Runtime.Remoting
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll.
----------------------------------------
FSUIPCClient
Assembly-Version: 2.4.4910.2.
Win32-Version: 2.4.4910.2.
CodeBase: file:///D:/Flightsims/FS%20Design%20Tools/Terrain%20Scupltor%20PRO/FSUIPCClient.DLL.
----------------------------------------
Microsoft.GeneratedCode
Assembly-Version: 1.0.0.0.
Win32-Version: 4.7.2612.0 built by: NET471REL1LAST_B.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.
----------------------------------------
mscorlib.resources
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/mscorlib.resources/v4.0_4.0.0.0_de_b77a5c561934e089/mscorlib.resources.dll.
----------------------------------------
System.Windows.Forms.resources
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms.resources/v4.0_4.0.0.0_de_b77a5c561934e089/System.Windows.Forms.resources.dll.
----------------------------------------
System.Drawing.resources
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing.resources/v4.0_4.0.0.0_de_b03f5f7f11d50a3a/System.Drawing.resources.dll.
----------------------------------------

<snip>
*****************************************************************
Remark: I've replaced my computer name by ****
Please let me know whether you need as well the system event text.
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
TS Pro doesn't (isn't intended to) need Flightsim to be running at startup. Do you have FSUIPC5 installed. If not, perhaps that's a situation I need to address - even though TS Pro should then use SimConnect.

Don
 
Messages
606
Country
germany
Do you have FSUIPC5 installed.
Nope, I'm neither using P3D v3 nor v4 and threfore FSUIPC5 wouldn't work. At the moment my plans making a restart with 64Bit is on hold because of the still lasting processor issues. My mainboard will not get any support by Asus as far as I know, but before building up a new one I'll wait until the fog lifts, disclosing the capabilities of future CPUs.
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Since you are using FSX, I should have asked, do you have FSUIPC installed

DOn
 
Messages
606
Country
germany
Since you are using FSX, I should have asked, do you have FSUIPC installed

DOn
Yes, it's the registered version, the most recent one (I should have mentioned it myself - but, while writing my last post I was called to supper and forgot to do it).
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Axel, attached is a newer version of TS Pro containing a number of bug fixes, including the startup (.tsd file) issue you reported earlier today. I was not able to reproduce the Flighsim startup issue nor your inability to compile a file.

Re the Flightsim issue, as you noted, these are NET errors - which I have never seen before nor have they ever been reported by anyone else. I'm not sure what more I can do in that regard. If you are still unable to compile your .tsd file with the attached version, please send me that file And I'll investigate.

Don
 

Attachments

  • TS Pro_0013.zip
    196.8 KB · Views: 159
Messages
606
Country
germany
Don, the good news is, that FSX doesn't need to be loaded, but unfortunately when starting to define the Blend Outline it first opens the respective parameter dialogue as expected but when hitting the Blend button it opens box to save the blending profile instead of starting to move the plane. When hitting the Cancel button I'm getting an (translated) "The index was out of range. I must not be negative and smaller than the selection." error exception.

1518962618685.png


The Details are as follows:
************** Ausnahmetext **************
System.ArgumentOutOfRangeException: Der Index lag außerhalb des Bereichs. Er darf nicht negativ und kleiner als die Sammlung sein.
Parametername: index
bei System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
bei System.Collections.Generic.List`1.get_Item(Int32 index)
bei Terrain_Sculptor_Pro.Nodes.SaveProfile()
bei Terrain_Sculptor_Pro.ProfileBlend.InitProfile()
bei Terrain_Sculptor_Pro.ProfileBlend.btnGo_Click(Object sender, EventArgs e)
bei System.Windows.Forms.Control.OnClick(EventArgs e)
bei System.Windows.Forms.Button.OnClick(EventArgs e)
bei System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
bei System.Windows.Forms.Control.WndProc(Message& m)
bei System.Windows.Forms.ButtonBase.WndProc(Message& m)
bei System.Windows.Forms.Button.WndProc(Message& m)
bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
************** Geladene Assemblys **************
mscorlib
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2600.0 built by: NET471REL1LAST.
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll.
----------------------------------------
TS Pro
Assembly-Version: 0.0.0.9.
Win32-Version: 0.0.0.9.
CodeBase: file:///D:/Flightsims/FS%20Design%20Tools/Terrain%20Scupltor%20PRO/TS%20Pro.exe.
----------------------------------------
Microsoft.VisualBasic
Assembly-Version: 10.0.0.0.
Win32-Version: 14.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll.
----------------------------------------
System
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll.
----------------------------------------
System.Core
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2600.0 built by: NET471REL1LAST.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll.
----------------------------------------
System.Windows.Forms
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll.
----------------------------------------
System.Drawing
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll.
----------------------------------------
System.Configuration
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll.
----------------------------------------
System.Xml
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2612.0 built by: NET471REL1LAST_B.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.
----------------------------------------
System.Runtime.Remoting
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll.
----------------------------------------
FSUIPCClient
Assembly-Version: 2.4.4910.2.
Win32-Version: 2.4.4910.2.
CodeBase: file:///D:/Flightsims/FS%20Design%20Tools/Terrain%20Scupltor%20PRO/FSUIPCClient.DLL.
----------------------------------------
Microsoft.GeneratedCode
Assembly-Version: 1.0.0.0.
Win32-Version: 4.7.2612.0 built by: NET471REL1LAST_B.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.
----------------------------------------
mscorlib.resources
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/mscorlib.resources/v4.0_4.0.0.0_de_b77a5c561934e089/mscorlib.resources.dll.
----------------------------------------
System.Windows.Forms.resources
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms.resources/v4.0_4.0.0.0_de_b77a5c561934e089/System.Windows.Forms.resources.dll.
----------------------------------------

Just to complete the information: I'm running Win 10 Pro Version 1709 (Build 16299.192) and everything is up-to-date.

I added the project file as requested.

EDIT: The "legacy version" of TS works now. It compiles correctly after I've changed the decimal point from "," (comma, used in German) to "." (dot).
The PRO version still doesn't work.
 

Attachments

  • VIDN.zip
    3.5 KB · Views: 169
Last edited:

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Attached fixes these issues. Look for another release in the next couple of days

Don
 

Attachments

  • TS Pro_0014.zip
    196.7 KB · Views: 167
Messages
606
Country
germany
Hi Don, a brief tests of the few functions needed to produce triangulation and a compiled file worked like a charm without showing any exception. Even colour change did it. :) Thanks for your prompt reaction.

After the first successful test, I changed my country specific decimal settings back to German (comma instead of dot) and got the almost empty BGL again and a .NET exception pointing in a direction of problems with the data format. I didn't too much programming the last 25 years or so, but as far as I remember .NET provides functions recognising and dealing with regional settings (I might be wrong as there was no need for me using it, but I think I read descriptions when searching another function).

Something new happened while conducting the second test. My INI file was configured to open the last project automatically when booting TS Pro. It did, but all lines, including the still present results of the last triangulation, appeared in yellow. After reloading the project it looked as selected before.

Meanwhile I returned back to the DOT (I don't have nationalism problems) and will try to explore other news of your tool.

Just before writing this I've tried the 'Load .bgl as background' function and used an ADE-produced CVX file which might not have been the intention. However, after loading I got as a result a grey dot, that appeared, after zooming in, to be a compilation of all polygons being included (in this example a background exclusion, the new airport flatten, and some polygons excluding autogen ), but all in the same light grey colour. The aircraft didn't move and a second attempt by using a default random .cvx file behaved the same way. Even if I have nothing more but a vague idea how this function could help, I think it could be beneficial displaying the shown region to (e.g.) 80% of TS' windows size and the plane (in case the flight sim is running) centered on its middle.

Just some thoughts...
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Thanks for reporting back. I didn't address the "dot" issue because I inferred you were only experiencing the issue in TS 1.2.09. Knowing now it's also in TS Pro, I'll fix it for the next release.

I haven't looked at the color or background code for a while. So, It's likely some other change I've made is causing the issues there. Background is supposed to be all medium-grey. It purpose is primarily to provide a reference for foreground actions. But it would appear there's a scaling issue. I'll investigate and fix.

Please report any other issues you discover, no matter how seemingly minor.

Keep tuned for another update soon. I'm also working with another user who is doing an exceptional job of testing and revealing shortcomings.

Don
 
Top