P3D v4 Last File Opened - Used

Just installed the 1.76 ADE. After settings completed, opened a airport bgl. When finished, I closed out. Question: Cannot find the "Last File Opened - Used" check mark box. Please help. Thanks.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
It is in Settings > Options > General .... Load Last Project. However you need a ProKey for that to be available. If you have a ProKey with an earlier installation then you can copy the file prokey.dll from the plugin folder of the old installation to the plugins folder of the new.
 
I reinstalled ADE 175. This is the only error message I get now in FSX. P3Dv4 works perfect. I have to have FSX because a lot of the older programs I use do not recognize P3Dv4. In ADE; where could I look to find this error?
 

Attachments

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Is this a file that is being loaded as 'last file used' ? e.g you are trying to load the project WCR_ADEX_ADE?
 
Sir: right now I cannot load anything. Pro Key does not work. I have created a monster. Look at what I found in the regedit. For some reason, I thought ADE would not put files into the register.
And I cannot delete these files safely; can I? Is there a safe register file cleaner that removes unused files available? Something simple. Free? Many thanks for your time.
 

Attachments

Pyscen

Resource contributor
The file above, in your original post, was that the last file you loaded into any ADE version you had installed?

Your last post has nothing to do with the error in your original post. What do you mean by Prokey doesn't work? The error has nothing to do with the Prokey either.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
The ADE installer may place entries in the registry to allow uninstall. There is no code in ADE that writes to the registry. There may have been such code in earlier editions. In any case it would only write the version and installation path. I can't recommend any specific registry cleaners but google should turn up plenty of safe and free options. Be aware not to remove any entries which are not orphaned. The ADE installer is third party and I cannot control what entries that makes in respect of the installation or uninstaller

This is the fix for the ProKey Issue: https://scruffyduck.screenstepslive.com/s/help_docs/m/20268/l/892318-could-not-load-file-or-assembly-xxxx-or-one-of-its-dependencies-exception-from-hresult-0x80131515

It is caused by a change in Windows File Security. You may find that more than one file triggers the error, so repeat the fix until ADE opens. You don't have a monster, just a well known and often posted file security error.
 
Today I installed the ProKey again in the new installation of ADE This is what I mean by not working. Before I opened ADE, I restarted the computer first. Then I tried opening as Admin. This is why I was wondering about the picture of the registry causing
some kind of issue. And it effect's me only - of course!
 

Attachments

DragonflightDesign

Resource contributor
As scruffyduck says, you've fallen foul of Windows security. Take a look at your second screenshot posted above: see that box down in the bottom right-corner that says 'Unblock'? Un-check 'read-only' and check 'Unblock' and then click 'OK'. No, I don't use ADE but I do see this problem on an almost daily basis at work. Windows is preventing ADE from talking to the prokey.dll. Scruffyduck provides the same steps in the link in the post above yours.

Also; you may very well have the same problem with the ADE installer. Check that the ADE installer doesn't have the same Windows-applied restriction on it. If the ADE installer is marked as blocked, I can guarantee that you've only got a partial installation. If it is blocked, as before, un-check 'Read Only', check 'Unblock' and click OK. Uninstall ADE and then - only then - re-run the installer.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Today I installed the ProKey again in the new installation of ADE This is what I mean by not working. Before I opened ADE, I restarted the computer first. Then I tried opening as Admin. This is why I was wondering about the picture of the registry causing
some kind of issue. And it effect's me only - of course!

But have you unblocked the files? You show screenshots with the files still blocked. It is not anything to do with the installer
 
Gentlemen; might be on to something here. I have no options to block or unblock in the installer.
 

Attachments

Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
that is because you are looking at the installer. you need to Unblock the files that come up when you start ADE
 

DragonflightDesign

Resource contributor
So as Jon says, you need to unblock prokey.dll. Checking the installer was a 'just in case'. Sorry if I muddied the waters slightly, Jon.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
If the Unblock option is not visible then the file has already been unblocked. Are you saying that ADE is still reporting an error with it and won't start or is it a different file? Sometimes more than one file needs to be unblocked to get ADE to start
 
Sometimes more than one file needs to be unblocked to get ADE to start: The program works fine. It was so convenient having the Open Last File. No error messages now.
But I am curious; which files should I look at? Many thanks to all.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Files to unblock? generally if is prokey.dll and infralution.licensing.dll which cause the problem
 
Top