• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v4 Library Creator 3.0 in RED

Hi all,
the last few days I'm experiencing more and more problems with Library Creator 3.0.
I make my models with Sketchup, Collada, MCX and export model as P3Dv4 MDL object (*mdl).
ALL my models are made for P3Dv4 (I always double check this because I've had problems with it in the past).
I place this MDL in a library with Library Creator XML.
I save my library in my scenery folder of my airport.
So there is the XML library and the BGL library.
So far so good.
When I look at the date now, they are not the same.
The XML is updated, the BGL is NOT updated.
I did not get an ERROR in Library Creator.

I also have several models in Library creator that are highlighted in red.
Even if they have sometimes been perfect in P3Dv4 for several weeks.

What went wrong?

EDIT: I've never had a problem with Library Creator in 12 years.
Last edited:

If models are shown in red in Library Creator XML that means that the MDL file of that model could not be found. Are you sure the MDL files are still stored in the same location as when you added them to the library? Having missing MDL files would also mean that the library can't be compiled to BGL.
Hi Arno,

I'm going to check this out as that could be the cause.

Thanks (again)
Hi Arno,
the models indicated in red, several of them had been moved.
That problem has already been solved (again something learned).

As for compiling, I searched but didn't find anything right away.
If I compile this library and rename it I do get a BGL.
I know this isn't the right way, but it works.
Now when I look in my scenery I have to see the 'absent' model.
And I can then insert it via Library creator in the library.
As described above, this is not the right way.
I have 4 libraries in my project, but when I add a model in a library and compile, I have the same problem again.
I've checked all my MDL and none are missing.
But still I can't compile to BGL.
XML does work.
Do you still have the names of objects in red?

And what does the log show when you compile the library? There should be some feedback like shown in the image below.

Hi Arno,
all red objects are gone, i have all objects in one folder now.
These are divided into four libraries.
This is library 1, and as you can see, saving the library works perfectly.
Library creator creates an XML, but not a BLG.
Library Creator.jpg
There must be another problem somewhere, Arno.
All 4 libraries create an XML, but no BGL.
I also can't compile my ADE anymore.
If bglcomp had some issues I would expect to see warnings or errors shown in the log. You could try to manually compile the xml file into a bgl. Maybe that works....
That's the weird thing, I don't get an error message.
So I completely uninstalled and reinstalled SDK. Checked all settings again (they were all correct) and...
Compiling works, a BGL is now created.

PS: With the program XML2BGL no BGL is created.
The program gives the message 'cannot find ... BGL'.
I can't read details because this pop-up window quickly disappears.

I absolutely wanted to know what the problem was and after some trying I came across something really strange!
I try first with Library Creator, compiling to BGL with Library creator does not work.
If I then compile with XML2BGL it doesn't work either.
But when I compile again with Library creator I do get a BGL.
I've done my four Libraries like this and all of four I get a BGL.
That's really weird. Have you tried compiling to another folder? This path is quite long and contains characters like [ and - which can give issues.
I'll try this right away and let you know.
What I did notice, when I compile with XML2BGL (as described above this does not work) that after compiling the Library BGL has disappeared.
As you suggested Arno, I have stored my Library elsewhere.
Everything works perfectly.
Was the cause the path was too long?
If yes, then the problem is solved.
Thank you Arno

I think it's either the length of the path or the non-standard characters in it. You could try a shorter path with these characters to figure out.
I just compiled the other 3 libraries and had no more problems.
I added an extra object in a library and no more problems here either.
So it will probably have been the length of the path.

Thank you Arno for your help.