Library Creator XML v2.0 (alpha)

Status
Not open for further replies.
#21
Hello another time,
Negative,

That makes it is to execute the new LibraryCreatorXML.exe, I select in options the route of the BGLComp.exe of FSX that I have in programa\Microsoft C:\Archivos Games\Microsoft Flight Simulator X SDK\SDK\Environment Kit\BGL Compiler SDK

then I believe a new New bookstore Library", I add the file terminal.xml,

I compile the BGL and it leaves me the error.

In the remote options I have marked the two routes that of the fs2004 and that of the fsx that I have in different places
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#22
Hi,

Which version number does Library Creator show in the bottom right corner? Because the error message you get indicates that the FsX BGLComp is used to compile a Fs2004 XML file. Maybe the tool has not determined the version correctly.
 
#23
Hello,
Me that makes it is to look for the route of the FSX BGLcomp like you see in the image, but in the corner it marks that it is the FS2004, I don't understand it.

Am I using the same MDL created with Gmax that used before, that it can be?
the MakeMdl, the same one that stops fs2004 is also?, have not I changed it.

When he/she believes the compilation, the BGL generated voucher for FS2004 and does FSX ?

 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#24
Hi,

The Fs2004 at the bottom indicates that the MDL files you loaded have been made with the Fs2004 gamepack. To be able to compile them into a library, you need to use the Fs2004 BGLComp as well. The error message indicates that somehow you are using the FsX BGLComp. If you are sure that you added the correct path the Fs2004 BGLComp, this could be a bug in the tool.

You can still use the library made with the Fs2004 BGLComp in FsX as well. But if you have made MDL objects with the FsX GMax gamepack, you need to compile them into a FsX library.
 
#25
Hi Arno

I'm getting the same error as Jon

"cannot set a value on node type element"

details -

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.InvalidOperationException: Cannot set a value on node type 'Element'.
at System.Xml.XmlNode.set_Value(String value)
at Library_Creator_XML.ApplicationConfiguration.setValue(String tag, String value, String attribute, String attributeValue)
at Library_Creator_XML.frmMain.mnuFileCompile_Click(Object sender, EventArgs e)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
LibraryCreatorXML
Assembly Version: 2.0.0.0
Win32 Version: 2.0.0.0
CodeBase: file:///C:/SceneryDesign.org/Library%20Creator%20XML/LibraryCreatorXML.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
 
#26
Hi Arno -

I may have a little more info for you. I removed then reinstalled library creator, and was able to make one library with no errors. A second attempt generated the error.

I noticed the librarycreatorxml.xml file was only created after I had chosen the path to bglcomp. I deleted it, set the path again, and was able to create one library again. But a second attempt failed.

Seems if I create a library, then edit the librarycreatorxml.xml file and delete the highlighted portion, I can create another library.

I would expect an issue with this xml file to affect everyone, but it seems to only be happening to a few of us. I'm confused, but thought I'd pass on what I've found.

At least I seem to have a found a way to use it for now.
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#27
Thanks Larry. Seems that something is wrong with the storing of the preferences in the configurations file. This week I have made a bit of progress on the tool again, so I am almost ready to release a new alpha version. I will also check the writing of the configuration part before I do so.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#28
I have made a new version available in this thread. So let's continue the discussion there.
 
Status
Not open for further replies.
Top