• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Load new scenery package without restarting sim

Blender2MSFS is the last problem

I don’t know but are u sure to have used the SimpleScenary? and not SimpleAirport! I fixed my bug using this package!

Try to open project and select the .bgl, open Inspector and set a new name of scenery. Build packages!
Load in editor, modify something, in scenery windows save the scenery.
Build packages again, just to be sure
Reboot FS2020 and....Good Luck


Roberto C.
Try before using the object3D without texture!


Roberto C.
 
Try before using the object3D without texture!


Roberto C.
I made some progress but I'm still not quite there. I managed to export a simple cube object with a single assigned material (albedo, Metallic and normal map) into the sim. When I built the package from the dev mode in the sim, restarted and selected the bgl, the cube showed up and could be placed but was without textures. Then I tried a method suggested in another thread, by compiling the files not within the simulator dev mode but by dragging the xml file onto the fspackagetool.exe from the SDK/tools/bin folder. This gave me a package complete with a texture folder containing the compiled dds files. I restarted the sim and to my amazement the cube showed up in-Sim complete with textures and all.
So I tried to do the same with my actual scenery models but there it failed again. I took the least complex object from my scenery, a small shack with three materials assigned, and exported it exactly the same way as the cube. Used the fspackagetool.exe on the xml aaaaand... Nothing. I got the following error messages from the tool:

Failed to load model xxx
Failed to spawn gltflister for input file xxx
Failed to spawn lister for asset group mymodellib

So unless I find a way how to rebuild my whole scenery with cubes, I'm still not getting anywhere.
 
I made some progress but I'm still not quite there. I managed to export a simple cube object with a single assigned material (albedo, Metallic and normal map) into the sim. When I built the package from the dev mode in the sim, restarted and selected the bgl, the cube showed up and could be placed but was without textures. Then I tried a method suggested in another thread, by compiling the files not within the simulator dev mode but by dragging the xml file onto the fspackagetool.exe from the SDK/tools/bin folder. This gave me a package complete with a texture folder containing the compiled dds files. I restarted the sim and to my amazement the cube showed up in-Sim complete with textures and all.
So I tried to do the same with my actual scenery models but there it failed again. I took the least complex object from my scenery, a small shack with three materials assigned, and exported it exactly the same way as the cube. Used the fspackagetool.exe on the xml aaaaand... Nothing. I got the following error messages from the tool:

Failed to load model xxx
Failed to spawn gltflister for input file xxx
Failed to spawn lister for asset group mymodellib

So unless I find a way how to rebuild my whole scenery with cubes, I'm still not getting anywhere.
Are u able to use Substance Painter? I’ve fixed the problem with it! If you need a help to export from it tell me and I’ll try to make a little tutorial!


Roberto C.
 
Are u able to use Substance Painter? I’ve fixed the problem with it! If you need a help to export from it tell me and I’ll try to make a little tutorial!


Roberto C.
Hello, Roberto! Can I watch your lesson? I have the same problem. The textured object is not assembled. No texture is fine
.
glTFLister | Failed to load model:
ModelLibLister | Failed to spawn the gltfLister for input file
PackageBuilder | Failed to spawn lister for asset group mymodellib (type ArtProj)
 
Hello, Roberto! Can I watch your lesson? I have the same problem. The textured object is not assembled. No texture is fine
.
glTFLister | Failed to load model:
ModelLibLister | Failed to spawn the gltfLister for input file
PackageBuilder | Failed to spawn lister for asset group mymodellib (type ArtProj)
Did you select the object in blender before exporting?
 
Top