FSX manually editing the default.xml to add new models

#1
Hi,
I followed the SDK tutorial for adding models to the default autogen.xml up until the point where my AUTOGEN EDITOR will not work.
After reading/wrapping my head around this way of manually editing the default.xml file, I am stuck at a point.....
I already have made the models (lights) and the are already in a .bgl file

I have placed the "lights".bgl into addon scenery and the textures into "texture" folder

I have a txt doc, created when i made the lights library.

Screenshot_10.jpg


as far as i know these are the GUIDS associated with the names of the light models.
I see in MCX there is a guid converter,

I am stuck at which ones i need to put in the default.xml file when editing it manually.

Do I convert these into (from fs2004 guids) to the FSX versions? Like so?

Screenshot_1.jpg


I see in the .xml file that most of the guids look like the first version, not the FSX style guid.


Screenshot_2.jpg



This is where i am stuck.
Could someone help clearify this for me as I am (after 4 years) finally getting close to the carrot dangling in front of my nose. :D
 
#2
another thing I failed to notice as I was writing this is where do I get a class - Name -Guid??


Screenshot_3.jpg


Thanks for reading, any help here would be awsome!!!!
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#3
Hi,

The default.xml file indeed uses the FS2004 style GUIDs, so you don't need to convert them.

The class name and class GUID are something you have to assign. So make a new random GUID and give your class a clear name :)
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#5
Just like you make a new guid for a model. Use a guid generator to give you a new random one.
 
#9
Hello,
I edited the default.xml file with this edit, but after saving it, I open it as and get this error. Do I have to add this section under all regions too?
xml problem.jpg



This is the error

xml error.jpg


Thanks for looking, thanks for your help!! I think im almost there!
 
#10
Hello:

Is Windows still configured with Windows Explorer (aka "My Computer" or "Computer" and Windows' default dialog file browsers) Menu > View -or- Control Panel > Folder Options ...set to default, such that file extensions are not being displayed in Windows Explorer or Windows' default dialog file browsers ? :scratchch

https://www.google.com/#q="Connot+view+XML+input+using+XSL+style+sheet"++"A+name+was+started+with+an+invalid+character"


If so, I would recommend enabling display of the full file name and extension in the title bar of task Windows capable of doing so to help avoid such errors, and that you generally not rely on Windows default "Open With" 'file associations' invoked via double-clicking in file lists of file browse dialogs (including Windows Explorer).


I would recommend using NotePad++ (aka "NP++" -or- "NPP"), Context or similar natively compatible text processors capable of properly displaying / editing XML files, instead of Windows NotePad, and that you only manually open XML files in order to edit them with those text editors (...rather than double-clicking XML files). :idea:


https://notepad-plus-plus.org/

http://www.contexteditor.org/index.php


PS: Note that although there are several other varieties of XML file formats used in the FS SDK, and some of them, IIRC, may not be saved as "UTF-16", FS install path > Autogen > Default.XML does <-require ?- > 'allow' for use of- the UTF-16 encoding format. :pushpin:

http://www.fsdeveloper.com/forum/threads/installing-custom-autogen-configuration.428760/page-2


GaryGB
 
Last edited:
#11
Thanks Gary. I have notepad++ up, so what could the red colored words mean, appearantly theres a problem, but I have no clue what to do next with this.

Screenshot_4.jpg


thanks!!

EDIT:
Found the source of the red errors. simple missed ">"
thanks!!

EDIT:
Still after fixing the error and saving, it will not open and still has error when opening.
I cant find the problem now, as there is no "red" text in the editor telling error.
 
Last edited:
#12
Hi again:

What error message does NotePad++ throw when attempting to (manually) open your edited copy of the [FS install path]\Autogen\Default.XML file ? :scratchch



You may wish to paste the XML code for your edited copy of the [FS install path]\Autogen\Default.XML file into this XML validator for a syntax check: ;)

http://www.w3schools.com/xml/xml_validator.asp


Note that for [FS install path]\Autogen\Default.XML there is no local context "external" XML schema (ex: a XSD or DTD file) utilized, so just paste the code in and click "check XML" button to perform a check of (only) the XML 'syntax'.


FS SDK BGLComp XML source code, however, does have a paired BGLComp.XSD which can also be used for validating those (different) types of XML source files if, for example one is repairing a mangled BGLComp XML file ...via a tool such as this one:

https://www.xmlvalidation.com/


Hope this helps a bit more ! :)

GaryGB
 
Last edited:
#13
Hi again,
I am really quite unfamiliar with .xml, but I can tell you this, The only lines I added - or that are different from the working default.xml are the ones right here at the beginning, I have highlighted. Unless there is something going on with these lines - there should be nothing else wrong with it, Thats whats got me perplexed - I am only using the guidelines from the sdk and examples from portions of other parts of the xml as a guide to what it should look like

Screenshot_5.jpg




Thats it! this is all I added, can anyone find a bad line or an error, because - even after editing it with notepad++ and saving - it still says there is some error, but i cant see any difference between the other parts(other lines) and what I have written here. this is really confusing.
 
#14
http://www.fsdeveloper.com/forum/th...ult-xml-to-add-new-models.439147/#post-762520

Hi again,

I am really quite unfamiliar with .xml, but I can tell you this, The only lines I added - or that are different from the working default.xml are the ones right here at the beginning, I have highlighted. Unless there is something going on with these lines - there should be nothing else wrong with it, Thats whats got me perplexed - I am only using the guidelines from the sdk and examples from portions of other parts of the xml as a guide to what it should look like



That's it! this is all I added, can anyone find a bad line or an error, because - even after editing it with notepad++ and saving - it still says there is some error, but I cant see any difference between the other parts(other lines) and what I have written here. This is really confusing.

http://www.fsdeveloper.com/forum/th...ult-xml-to-add-new-models.439147/#post-762517

Hi again:

What error message does NotePad++ throw when attempting to (manually) open your edited copy of the [FS install path]\Autogen\Default.XML file ?
IIUC from what you have described (again), NotePad++ continues to report errors after editing your working copy of the [FS install path]\Autogen\Default.XML file; please post a screen capture of the error message(s) and attach any such image(s) to a reply to this thread. :pushpin:


Also, if you would please paste into a reply to this thread, the actual "text" copied from NotePad++ (and not 'Windows NotePad' as seen in your latter screenshot above) which is highlighted in blue for your custom "XML elements" that you edited into your working copy of the [FS install path]\Autogen\Default.XML file ...it would help us help you better. ;)

GaryGB
 
Last edited:

MOUSY

Resource contributor
#15
At first glance, your last <LIBRARYOBJECT> tag is missing a / in order to close it.

P.S: If manually building the default.xml is to much of a hassle for you, you can edit a copy of the default using the AutoGen Editor in the P3D SDK. (The FSX version does not work). It also automatically validates any default.xml you load and reports errors.
 
#18
Mousy you apparently hit the nail on the head, as soon as i added that character, the script became working, at least it opens like the unedited one does.

Now off to the races!

I will report back with results, THANK YOU ALL for helping me out. VERY MUCH APPRECIATED!
 
#19
At first glance, your last <LIBRARYOBJECT> tag is missing a / in order to close it.

P.S: If manually building the default.xml is too much of a hassle for you, you can edit a copy of the default using the AutoGen Editor in the P3D SDK. (The FSX version does not work). It also automatically validates any default.xml you load and reports errors.
Hi Mousy:

Although the OP has indicated elsewhere that his KDAY project is intended for the P3Dv3.x version of FS, this thread is labeled as pertinent to FSX.

http://www.fsdeveloper.com/forum/threads/work-in-progress-kday.433583/


Bearing in mind that one would otherwise be compelled to utilize the MS-FSX SDK or LM-P3Dv1.4 SDK for FSX development, and because I don't develop for P3D (yet), after reading prior threads on issues of reportedly different functionality for MSFS vs. LM-P3D SDK Autogen Editor:

http://www.fsdeveloper.com/forum/threads/autogen-editor-instant-crash.438705/

http://www.fsdeveloper.com/forum/threads/autogen-editor-and-region-problem.429635/


...I'm therefore rather curious as to whether you have seen any difference in functionality of: :scratchch

* LM-P3Dv1.4 SDK Autogen Editor compared to the original MS-FSX SP2 SDK ?

* LM-P3Dv1.4 SDK Autogen Editor compared to the LM-P3Dv3.x SDK Autogen Editor ?


Thanks in advance for sharing any further information you may have with regard to functionality issues with the above versions of Autogen Editor. :)



PS: The OP may also wish to perform a more detailed validation of the FS default.xml file and all defined objects therein ...via use of: :idea:

[FS SDK install path]\SDK\Environment Kit\Autogen SDK\AC2Scan.exe


https://msdn.microsoft.com/en-us/library/cc526979.aspx#AutogenValidationTools


GaryGB
 
#20
Thanks Gary, Ill takea look at this here in a little bit. I have about 5 different projects going full blast 24/7 so I like to break up my working cycle by alternating between them. I am developing for both FSX and P3Dv3+, and so far everything i have made works the same on both sims. I mainly use FSX for testing, and P3D for when I really want to fly seriously. But as of now thats the goal. I just spent the last 8 hours, replacing every single taxiway texture and enhanced runway entrance texture on the whole airport, with better suited textures. I am everywhere, but I am focused.:coffee:
 
Top