• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FS2004 Map & GPS Airfield/Seaplane base symbols question

Leo2789

Resource contributor
Messages
220
Country
portugal
Hello!

I am developing an extensive scenery for FS2004, and recently decided to change my workflow regarding airport design tools; whereas I used to make the AFD file itself using AFX, and only use ADE to then add objects to the airfield, I've decided to now use ADE from the start. In doing so I've come across a curious detail that has me wondering if/how I could change this.
Here is a snap of the sim's Map view (GPS shows the same), of 2 seaplane bases in the same lake that are close by:
water1.PNG

I used to have all these in the sim represented with the rightmost anchor symbol (no circle) when all were generated from files made with AFX (and even in many default scenery seaplane bases I've encountered like all around Alaska for instance). The leftmost symbol, I had never seen before! And since I switched to ADE-only files, a few of the seaplane bases created for my project now show up with the leftmost symbol! So far I haven't found any clear specification they have in common, I thought water runway length could be a trigger for the symbol to change, but there's no clear threshold for this, as there are bases with no circle that have longer runways than others with a circle... Also I don't recall doing any editing in ADE in some bases that I didn't in others so this is very confusing to me o_O.
Essentially what I want to know then, is:
#1 How is this symbol generated (what are the specs or setting needed for it)
#2 Why did ADE made a few of them appear with this symbol and not others?
#3 Is there a feature or setting that controls this in ADE?

On a related note there's also the difference between "filled circles with runway depictions" vs ''just a circle'' for the representation of airfields on land, example:
airfield1.PNG

Now I know that BLUE airfields are those that are controlled (ie have a tower frequency assigned to them), and that magenta ones are uncontrolled airfields. From comparing dozens of these airfields, I concluded that what triggers the different symbol is whether the airfield has a paved surface runway or not. Is this correct? If not (or not the only reason) what other reason/setting is there then?

I hope someone with knowledge of this can impart some wisdom regarding this!

Thank you
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,522
Country
unitedkingdom
The only connection ADE could have with the GPS is via approach code. AFX does not support approaches, ADE does. I can only imagine that this might happen when an airport is compiled. I have zero knowledge of how the sim map view and gps work.
 
Messages
1,360
Country
scotland
Hi Folks

Leo -
Circle with Ticks == Airport with fuel
See attached.

HTH
ATB
Paul
 

Attachments

  • AirportsInfo.gif
    AirportsInfo.gif
    66.3 KB · Views: 175

Leo2789

Resource contributor
Messages
220
Country
portugal
The only connection ADE could have with the GPS is via approach code. AFX does not support approaches, ADE does. I can only imagine that this might happen when an airport is compiled. I have zero knowledge of how the sim map view and gps work.

Hey Jon!
I didn't add any approaches for these though, and it doesn't feel like something that's related to the map or GPS themselves, more like something to do with the airport's BGL, which Paul has explained/confirmed in the post below yours.
Thanks for replying :)

Hi Folks

Leo -
Circle with Ticks == Airport with fuel
See attached.

HTH
ATB
Paul

Ohhhh! That makes total sense! All the seaplane bases that now show with this circle & ticks are the ones where I've made fuel available!! The thing is that when the AFD file for them was generated by AFX, there is no way to edit 'Services' in that program, and even though I had a fuel trigger object placed through ADE, it appeared in the sim with no circles. Now since ADE has the option to edit Services (essentially Fuel) in the Airport Properties, I did edit those for all the seaplane bases where I had made fuel available through a fuel trigger object! I couldn't remember any edits I had done when moving from AFX to ADE, but that was it! :)
I assume that if I specify fuel in the services of a land airport, it would be rendered with the ticks as well right?
By looking at that legends you attached it seems I am also correct in assuming what I did regarding the difference between filled and non filled circles for land airports! :)

Many thanks for your help and shedding some light on this Paul! :)
 

Leo2789

Resource contributor
Messages
220
Country
portugal
Hello!

I am reviving this thread because I have now come across a sort of 'opposite' problem :rotfl:
I've been assigning Fuel availability in the Services tab of Airport properties in my ADE projects and so far have gotten the results I wanted, except in a particular airfield, where despite assigning fuel availability, in the Sim's map it shows an airfield with unpaved surfaces (so far correct) but with no 'ticks', ergo no services/fuel! I've tried a lot of different options and troubleshooting but no dice.. The same thing happens on yet another airfield which also has unpaved runways; the only thing these airfields have that would be 'different' from others which show correctly in the map is that they have more than 1 runway; could this be the reason? I have a hard time believing that is the issue..
example1.PNG Properties window, where fuel availability is selected as YES!

example2.PNG

The offending airfield is at the center of that snapshot: 'Amareleja'
Notice how SE of it there's another unpaved runway airfield with fuel services assigned to it which shows in the Sim's map as it's supposed to.

I have attached my ADE project files in case someone wants/needs to open it to help me figuring out what's missing here!

Thank you!
 

Attachments

  • ADE_LP10.zip
    17 KB · Views: 142
Last edited:
Messages
1,360
Country
scotland
Hi Folks

Leonardo -
ATM I can't check your ADE file,
as the power supply has failed on my main machine.

However
from inspecting your XML file,
it contains lots of sceneryobjects,
but the AIRPORT xml itself, contains no FUEL tags.

Hence no Circle with Ticks

Extra -
Does your WINDSOCK display/work ?
ISTR previously that 2 WINDSOCKs needed to be placed for them to work.

HTH
ATB
Paul
 

Leo2789

Resource contributor
Messages
220
Country
portugal
Hi Folks

Leonardo -
ATM I can't check your ADE file,
as the power supply has failed on my main machine.

However
from inspecting your XML file,
it contains lots of sceneryobjects,
but the AIRPORT xml itself, contains no FUEL tags.

Hence no Circle with Ticks

Extra -
Does your WINDSOCK display/work ?
ISTR previously that 2 WINDSOCKs needed to be placed for them to work.

HTH
ATB
Paul

Hey Paul!

Thanks for chiming in!
Indeed it has quite a few objects added! I also checked the airfield in question's xml file and there is no services section.. :scratchch Which I did find on the xml of other airfields I had assigned fuel to; the weirdest part is that as you can see in my snapshot, I DO have fuel available in the services tab when working on ADE. I didn't think to check that because tbh I never really touched xml, I've opened files and understood the basic logic behind them but never actually edited/coded one myself.
Still, nothing is different in that airfield's project from other projects with fuel assigned...Again the only 'common link' between the 2 airfields that manifest this issue is that they have more than one runway, but that shouldn't have any influence on the matter right?

As I understood the windsock question, you are asking if the ones I placed work? Most of my airports are very small and so only have 1 windsock (for those that DO have one lol), and it shows up in the sim and works fine, stretching and turning from wherever the wind is coming.
 
Last edited:

Leo2789

Resource contributor
Messages
220
Country
portugal
Ok very weird...
I wanted to give it a go at this again and opened the airfield in question's project in ADE and to my surprise, the fuel was all selected as 'NO' in services, which I'm 100% sure I had changed to YES, I even took the previously posted snapshot of it :eek:
It appears I've been a 'victim' of some sort of bug? I noticed before that sometimes when I opened some airport properties in ADE it would default the services of that airport to the ones the previous opened one had for some reason o_O
Maybe that happened while I kept opening and closing various projects to try and troubleshoot this, making me select the fuel as YES, but as I closed the project, opened another one, and opened this one back again it had 'reset' to NO on all fuel listings and I compiled the BGL unaware of such change? o_O:oops:
Anyways it appears the problem solved (??) itself, or at the least things are working as intended; guess I'll just have to double check services when compiling airports :rotfl:

Thnx for your input again @BASys
 
Top