P3D v4 Max 2017 & PBR Materials

n4gix

Resource contributor
#1
I have recently (as in a week ago) had to begin working on projects using P3Dv4.4 PBR Materials. However, in my Max 2017 none of the PBR albedo textures are being used in the Max Viewport, which makes further work exceedingly difficult!

Has anyone a clue as to what I need to do to get this working properly?

 
#4
I had a similar issue with Max 2017 where using PBR textures caused the script window to open with an error. The albedo texture would show up as white. What I did was go to Customize> Preferences> Viewports and changed the driver from Nitrous Direct3D 9 to Nitrous Direct3D 11. This fixed the issue for me.

Your problem could be related to this.
Screenshot_24.jpg
 

n4gix

Resource contributor
#5
Thanks. My issue was a bit more complicated, but between your hint and that of two gentlemen from SOH, I've now got full color textures again! :cool:

I didn't have the DX Mode option showing in my Max 2017 until I followed the steps below:



After a few minute of Google-Fu, I learned that I could use the Start Menu to change the driver from here:



This then launched Max 2017 and it only listed "Nitrous DX9" as the active driver in the Preferences/Viewports tab. When I closed Max 2017 and re-launched it, I now had "Nitrous DX11" as the active driver.
 

n4gix

Resource contributor
#9
To report the solution that worked for me, I got this from Andras in the Prepar3D forums:
Andras post_id=194309 time=1551567314 user_id=556 said:
Ideally you need to change both the "production" and "material editor" renderers to Quicksilver hardware renderer.
If you don't do that for the second one, you will only see almost empty, white preview boxes or spheres in the compact material editor.
Thank you Andras. In my case the switch to Quicksilver in both production and material editor solved my problem. :)

Note: Press F10 to open the Render Settings dialogue, go all the way to the bottom and set both production and material editor to Quicksilver:

 
Top