FSXA MDL Tweaker II error

#1
Hi all,

I have very many .MDL files that I created with Gmax - all compile properly with BGLC and all work fine in FSXA.

I wanted to try and use MDL Tweaker II (the latest install 2.0.0.266 to remove the shadows from an object.

The program launches correctly but I get a message for all my .MDL files that "Error 100 (This not a valid RIFF scenery MDL file) in procedure mOpen_Click of Form Form 1"

The loading progress dialog says "currently loading the MDL headers - but never finishes...

Any ideas?

Geoff
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi Geoff,

Are this FSX MDL files or FS2004 MDL files? FSX MDL files are not supported by MDL Tweaker. But in FSX you can disable the shadows in the XML code when you place the object.
 
#3
Arno, they are FSX MDL files - I think I remember now that MDL Tweaker doesn't work with these XML types!

I tried placing the <NoShadow/> statement in the XML file but I can't figure where to put it, the SDK doesn't seem to show an example?
I tried many different places but it fails to compile with BGLComp.exe

My XML file looks like this:

<?xml version="1.0" encoding="ISO-8859-1"?>
<FSData version="9.0" xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'
xsi:noNamespaceSchemaLocation="bglcomp.xsd">
<ModelData
sourceFile="FreewayBridge.MDL"/>
</FSData>

It compiles just fine normally and I place the object with "Whisplacer"

Any assistance is much appreciated!

Geoff
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#5
Hi,

Or in case you want to do it in the XML, the NoShadow command goes within the SceneryObject command, together with the LibraryObject command.

But doing it from WhisPlacer is easier of course :D.
 
Top