MIPs used on Scenery Objects

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Exporting the model does not affect the textures. But when you save the textures mipmaps are created by default.

Textures without mipmaps can cause issues like blurry textures in fs.
 
#3
. . . . .Textures without mipmaps can cause issues like blurry textures in fs.
Actually it's just the opposite. I was having trouble with every hangar texture I had until I remembered the mips. I went back and resaved all of them without the mips and all are clear and crisp. They may be handy at times, but with scenery that will be viewed close up and scrutinized as this project will, mips are a no-no. Same goes for aircraft textures.
 
#4
Actually it's just the opposite. I was having trouble with every hangar texture I had until I remembered the mips. I went back and resaved all of them without the mips and all are clear and crisp. They may be handy at times, but with scenery that will be viewed close up and scrutinized as this project will, mips are a no-no. Same goes for aircraft textures.
removing mips is bad idea imo. Not only you will waste GPU memory by drawing full resolution at all times, but you ll also have problems with shimmering at distance due to lack of filtering.

If smth is to be scrutinized from close by, then removing the mips will not offer any help at all since mips are only used in distnace.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#5
Removing mipmaps is for sure not always the best idea. Is this for FS2004 or FSX?

In FS2004 there are many threads about the entire scenery going blurry. 9 out of 10 times this is caused by the texture without mipmaps. Adding them solves this issue.

When the textures do not display sharp with mipmaps that can also be caused by bad texture design. If you mix elements with a very different resolution it seems FS has trouble to pick the right mipmap. For example one half of your texture is mapped on a 10 meter big object and the other half on a 1 meter object. The 10 meter big objects needs to show a more detailed resolution from a greater distance than the 1 meter one (assuming they are both covered by the same amount of pixels). The engine does not handle this well, so it is better to make sure the resolution (pixels/meter) is rouhgly the same for all parts of your texture.
 
#6
removing mips is bad idea imo. Not only you will waste GPU memory by drawing full resolution at all times, but you ll also have problems with shimmering at distance due to lack of filtering.

If smth is to be scrutinized from close by, then removing the mips will not offer any help at all since mips are only used in distance.
Ok, then why were the textures blurry close up and crisp after removing the mips?
 
#7
Removing mipmaps is for sure not always the best idea. Is this for FS2004 or FSX?

In FS2004 there are many threads about the entire scenery going blurry. 9 out of 10 times this is caused by the texture without mipmaps. Adding them solves this issue.

When the textures do not display sharp with mipmaps that can also be caused by bad texture design. If you mix elements with a very different resolution it seems FS has trouble to pick the right mipmap. For example one half of your texture is mapped on a 10 meter big object and the other half on a 1 meter object. The 10 meter big objects needs to show a more detailed resolution from a greater distance than the 1 meter one (assuming they are both covered by the same amount of pixels). The engine does not handle this well, so it is better to make sure the resolution (pixels/meter) is rouhgly the same for all parts of your texture.
All the textures I used are the same resolution. This is an FSX project. I understand the passion that some folks have about mip maps and I admit that I am far from expert in any of this, I am learning. . .or trying to, but for me, the proof is in what I see with my own eyes and as far as I'm concerned, while mips have a following, with the way PC's have grown in their ability to display our Sim World. . .their importance is greatly exaggerated. I've seen them cause more problems than solve them. If mips are used only for distance and all the textures are set at the same resolution, then why, when I remove them does the texture go from blurry to sharp? It's cause and effect as far as I'm concerned. Sorry to be so vehement in my objection to the suggestions here, but this has been a long project, a very good learning process to be sure, but given the nature and importance of this Aerodrome, it's imperative that all the textures be sharp and removing the mips has done that.
 
#8
It is not blurry closeup, maybe you are not close enough to show full size :D
But to be honest it is true, that you need to be too close to see full size - next to smaller one up. Sad that there is no distance switch do define when you want the texture to be switched at.
 
#9
here is an example, when texture was without mips it was sharp and crisp at all distances and start to flickr the further you are.
At the same time I understood that if I will go from 1024 to 512 in size, flickering problem will be solved but against quality. So I want the grass is the grass , not blurry thing.. Then remembered mips... As I said before quality has not gone at near but far, exactly what I wanted. Sad not distance I wanted at.



MIP-texturing do not solve the problem of texture at an acute angle to the viewer (e.g., runway or taxiway). Such texture resolution along one axis is different from the resolution in the other, for example X-axis image is obviously blurred, while the Y-axis visible. There are several ways to solve it.

1. Set the video driver to the most comfortable value of mip bias - a number that is responsible of a pyramid of textures. If it is negative, the video card takes more detailed textures, if positive - less detailed.
I was unable to find this in Catalyst control of my video adapter

2.Many of the games themselves set the appropriate mip bias for different types of objects.
Could somebody tell where is this in FSX ?

3.To use anisotropic filtering - by texturing, which is aiming the solution of this problem.
Absolutely dark picture to me..
 
#10
Textures in FSX are difficult to work with due to FSX having a distance blur built in. make sure that the global max texture setting is up at max or "massive"
for best results in FS9 DXT1 will give you what you need but DXT3 is by far more frame rate spending. if you are texturing ground I would suggest DXT1 to save on FPS but for objects DXT3 with no mips is defiantly the way to go. also try and use 1024x1024 bpm and squeeze as many parts of your object's textures into a single image, for smaller parts use smaller textures 256x256 and 512x512.
This will reduce load on your computer and FS won't need to load multiple images for each object.
I have been creating scenery for many years. Although I may not be a professional if there is one thing I do know its textures.
Another cause for blur on textures (with or without mips) would be general computing power. if your scenery has many textured objects FSX and 9 will blur at a certain distance to reduce workload. This can be fixed by turning down terrain mesh and lowering the sliders that control the graphic options leaving "Global Max Texture size" at massive.

Hope this was of some help.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#11
Always use dxt1 for the textures, also of objects. You only need dxt3/dxt5 when you have an alpha channel. Using dxt3 for an object without transparency is a waste of memory. The color information is stored the same in both compressions.
 
#13
Well, I am at a cross roads and I know which way this will probably go, but to reiterate; I have approx 18 hangars, plus another 10 to 12 smaller buildings that require the textures to be clear and crisp. This is Old Rhinebeck, which has a huge following and has been visited by thousands over the years. The scenery is interactive in that you can walk around it and get a good feel for what it's like to be there (that's what I'm hearing from the beta folks). I started out with dds/mips. The textures were blurry close up (the original textures are all very hi-res) so I removed the mips. . .textures are sharp and just as they should look. The tradeoff seems to be that without the mips, the dreaded "shimmering" that was present in FS9 when you ran the mipmap setting up too high, is present here due to lack of any mips. Yet with the mips the textures go blurry and to be honest. . .looks like crap. So despite the claim that mips are only for distance and have no effect on the textures close-up, it would appear that this is not always the case.
 
#14
So despite the claim that mips are only for distance and have no effect on the textures close-up, it would appear that this is not always the case.
This is not a claim, it is how the GPU works. It gradually switches to lower mip levels as you move away from the texture.

If your textures are only good without mips, this means that your initial resolution is not good enough.A big texture sheet (2048 or 4096) does not always mean good resolution. what is important is the px/cm ratio on your models.
 
#15
This is not a claim, it is how the GPU works. It gradually switches to lower mip levels as you move away from the texture.

If your textures are only good without mips, this means that your initial resolution is not good enough.A big texture sheet (2048 or 4096) does not always mean good resolution. what is important is the px/cm ratio on your models.
Interesting. . . .
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#16
If your textures are only good without mips, this means that your initial resolution is not good enough.A big texture sheet (2048 or 4096) does not always mean good resolution. what is important is the px/cm ratio on your models.
Yes, and as I wrote in post 5 already, that px/cm ratio should be ratter consistent over the entire texture sheet. Else the mipmaps can switch at the wrong distance.
 
#17
Hi Folks,

Thanks for providing a toggle in MCX for mipmaps Arno!

Noting to FsFox's comments above, I think I have discovered something regarding my transparencies in FSX and P3D and I'm wondering if I am right. I was still not completely happy with them, especially when one is in front of the other; the result is often a blocky look like the picture I posted here:

http://sdrv.ms/19t0enz
Sometimes the border of the opaque part will even have a very dark outline.

I've now tried a few of my more complex models without mipmaps, and the blocky transparencies previously seen at certain distances are now gone. Much better. The tradeoff is that at intermediate distances I sometimes now see a flickering line for things like railings and antennas, but on the whole it's a lot less distracting than the blocky outline.

But I think I Arno put his finger on the real source of my transparency issue based on the way I've been making my latest models. I start with a 2048 x 4096 side view photo of the boat, made as large as possible and use all the extra space in what becomes a texture for parts of the boat; some are big, some are small, and more visible or more important parts have a higher px/cm ratio. (Where in the past I might have used 20 to 30 different materials in Sketchup I now have one or two plus a couple of colors. If nothing else it makes editing in Photoshop a lot easier.) So I'll bet the fundamental problem is that the mipmaps are switching at the wrong distance. Does that make sense?

So I'm wondering if I should remove all the mipmaps from my objects that use a lot of transparencies.

Any thoughts?

Thanks much,

Larry
 
Last edited:

hcornea

Resource contributor
#18
Preview your objects using the checkerboard.

The checks should be the same size.

If not, mip switching will not occur at the correct level. Put another way, the Sim cannot display more than one mip level for the same material.

So evening out texel density will improve mip loading/switching and transparency.

Note that dithered grey alpha on transparent objects can give haloes as it can cause issues with Z-testing.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#19
I'm not aware of any mip toggle in ModelConverterX, so for sure I didn't add anything :)
 
#20
Hi Arno,

I must be dreaming about something new. New to me maybe? Under Options / Texture settings / I changed AddMipMap from True to False. It must be doing something, because the dds file size goes down. :)
 
Top