FSXA Misplaced parts after FS9 to FSX export

#1
Hello Arno,

I am trying to convert the G6's S2TCiv Tracker from FS9 to FSX, but I am facing a pretty peculiar bug.
Here is a picture of the enclosed s2tciv.mdl opened in the latest dev release (8/8/18). Everything looks fine.
Then I click on "export model", save as FSX MDL object. I close and restart MCX, reopen the exported model, and ooops, the wings have gone mad! The wing fold anim is lost, but wings look as if they were folding. I did the conversion several times, and each and everytime the wings want to fly by themselves.
Do you have any idea about what could lead to this crashed model?
Thank you!
 

Attachments

#2
You need to replace the FS9 animation tags which are incompatible with FSX/P3D. The wings use FS9 l_wingfold / r_wingfold tags, they should be replaced with FSX wing_fold_l_pct / wing_fold_r_pct. I did not check if there are more FS9 specific tags used in your model but usually these parts get misplaced after export to FSX/P3D format.
 
#3
Arno was working on improving the FS9 to FSX conversion, but I think he ran out of time. Make sure that the Options/Importer settings/Use conditions is set to UserSpecified; that usually causes the least problems.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#5
You need to replace the FS9 animation tags which are incompatible with FSX/P3D. The wings use FS9 l_wingfold / r_wingfold tags, they should be replaced with FSX wing_fold_l_pct / wing_fold_r_pct. I did not check if there are more FS9 specific tags used in your model but usually these parts get misplaced after export to FSX/P3D format.
I'll try to add these to the automatic conversion list that we discussed a while ago.

But as Tom said, at the moment my focus is more on scenProc so this is a little bit on hold again.
 
Top