P3D v4 Missing Aircraft Objects In Library

#21
That library displayed there is a default FSX library, and I assume is in FSX format. That makes it incompatible with FS2004. If you have FSX you might be able to convert it using MCX though, for personal use.
 
#23
I am still lost in trying to get the big thumnail pack to get recognized in the ADE. I followed the instructions that duck had on the site, but I am doing something wrong I guess.
It says, can't find BGL file, and all sorts of problems... no added thumbs... I just want to try to add a thumb so I can put a 737 on the airfield in a static parking place, and not use the ones that are avail.

Anyone have a link to a youtube video or anything to help....
Thanks for the assistance, I am a newbie.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#24
the big thumbnail pack does not have bgl file in it. Can you please provide some screen shots of the error messages that you are getting and tell us when they happen.
 
#25
I looked in the big thumnail folder manually, found folder with aircraft. Bingo, there is a 737. I can’t seem to get ADE to see this folder, where the 737 and other aircraft are shown. I just want to place a 737 on a ramp.

the rest of the ADE is awesome, its working really well at editing my airport.
Anyway to buy a version that has this type of scenery already going?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#26
Where did you install the Big Thumbnail Pack? Have you pointed the Library Object Manager at the folder where it is located?

1549796635942.png


Also please understand how ADE works in delivering a thumbnail for a placed library object. Each object has a unique identifier called a GUID. ADE uses the GUID of the object you select or place to look for a thumbnail in the folder structure defined above. If it is found then the thumbnail will show up. The BTP is just a collection of small pictures of objects. It does not contain any objects itself. So you never place anything using the thumbnail but rather using the object data. Place something using the Right Click Menu

1549796895301.png



1549797333335.png


There are the 737's showing thumbnails So I can add it (I can add it whether or not it has a thumbnail of course)

Here is the result:

1549797435257.png


The object will show with its correct shape if you have detailed object footprints active. The tooltip (if you have them turned on) will show details of the object including the thumbnail if available, In any case it displays the name and which library object bgl file where the aircraft model is stored.
 
Last edited:
#27
Where did you install the Big Thumbnail Pack? Have you pointed the Library Object Manager at the folder where it is located?

View attachment 47719

Also please understand how ADE works in delivering a thumbnail for a placed library object. Each object has a unique identifier called a GUID. ADE uses the GUID of the object you select or place to look for a thumbnail in the folder structure defined above. If it is found then the thumbnail will show up. The BTP is just a collection of small pictures of objects. It does not contain any objects itself. So you never place anything using the thumbnail but rather using the object data. Place something using the Right Click Menu

View attachment 47720


View attachment 47721

There are the 737's showing thumbnails So I can add it (I can add it whether or not it has a thumbnail of course)

Here is the result:

View attachment 47723

The object will show with its correct shape if you have detailed object footprints active. The tooltip (if you have them turned on) will show details of the object including the thumbnail if available, In any case it displays the name and which library object bgl file where the aircraft model is stored.
I get it just references the data, and the program will populate the aircraft or the object if its in the simulator as an actual model.
I just don’t even get the words in the thumbnail lookup..

I placed the whole folder in P3D v4 folder in ADE called thumbs. Does it need to be in the Lockheed Martin p3D program folder?

I have all sorts of other planes available in that pull down box that came with ADE, just not any commercial planes other than the A380. Thank you for creating ADE, and keeping it going!!! and Thanks for your help here!!
 
Last edited:
#28
Why would the 737 not show up in the list on my version of ADE? is it an issue with P3Dv4?

Have another question, I have objects that show up as the wireframe kind of image on ADE, when I take that file to another computer, and use the ADE i installed on it, I just get big yellow boxes, not the e outline of the image. The blimp looks like a blimp on my computer, and then when I load it on another computer, the ADE image looks like a big yellow square, If I hover over it the thumbnail is the same and shows the blimp. but does not show the nice wireframe.
 
#29
Well, the 737 is in a library called vehicles_aircraft.bgl. Do you have that? In the ADE Tools/Library Object Manager click the drop down arrow next to the top entry, Library. In the resulting list, do you have a vehicles_aircraft.bgl file? If not, then the thumbnail will never display because you don't have the object belonging to that thumbnail. That big thumbnail pack has pictures for many more objects than comes with a default installation, I assume.

Hope this helps,
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#30
The wireframe display in ADE appear when you have detailed footprints turned on. Detailed footprints have been available since version 1.7x if the other computer has an older version then they will not display. Also they will not display if you have them turned off in settings. Settings > Options > General Tab

Turned on
1550990212446.png

Turned off
1550990252266.png
 
#31
The weird thing is the detailed footprints check box is on, still get square blocks.
Think I need to reinstall?

Is there another area, I need to adjust?
 
#32
I loaded another airport, and it worked on it.
Then reloaded my project airport and wireframe is going...
Not sure what was going on...

Thanks for the help.
 
Top