• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Missing Ground Markings

Messages
26
Country
us-ohio
On a couple of my airports (KCAK, KCMH) a couple of users (and I mean only a couple...lol) have mentioned that they are not seeing ground markings on the aprons. However, I see them just fine (obviously since it is "on" my system). I had one person who downloaded my scenery (flightsim.to) post some screenshots and the markings were there on his install. However, being one who gets troubled by such things....lol....I still wanted to investigate any "wrong doings" by me. I could not really find anything. I checked apron priorities (nothing out of the ordinary there...all logical settings....no overlaps with the same priority) and of course painted lines do not have priority settings.

I usually do my airports with two packages, one for the airport (runways, taxiways, signs, aprons, lines, etc...) and one for the buildings. Not sure if that workflow is logical, but it sure makes updating a lot easier and less stress on my computer (which I'd say is no slouch though not a total beast....i7 10th Gen, 32GB Ram, 6GB GPU memory...I'm a Cartographer and my mapping software is more demanding than MSFS).

Basically I am asking.....should I not be concerned since it is NOT a universal issue? It still vexes me....lol.
Plus, I use Blender 2.9 and was wondering if doing ground markings within Blender is a better route than in the scenery editor of the SDK....I'm always eager to learn new techniques and workflows.

However....there are a few who talk about seeing "pink" from far away, but that is a topic for another time since I hear that Asobo knows this is an issue with many.
 
Messages
276
Country
unitedkingdom
Ground markings as in painted lines?

I don't know if they've addressed it because I do it automatically now, but with my first efforts the painted lines would either not appear or be broken unless I gave them a characteristic in the line's properties.

Right click on it and you have 'all points' to make it straight and I can't remember the bendy one. You have to manually add that setting to each line or it might not be visible when built.

Since you're opening it in development mode you're going to see them intact even after you leave. Others may not.

If you're already doing that then I can't really think of any other reason.
 
Last edited:
Messages
253
Country
germany
Pink always meems that the sim is not being able to use the texture file correctly that the developer put at that certain place. This can have two reasons:
1. the texture file has not been converted correctly because it's not in the wright format of binary factor (512x512 or 1024x1024 or ....)
2. the file is missing in the texture directory.
 

=rk=

Resource contributor
Messages
3,427
Country
us-washington
Pink always meems that the sim is not being able to use the texture file correctly that the developer put at that certain place. This can have two reasons:
1. the texture file has not been converted correctly because it's not in the wright format of binary factor (512x512 or 1024x1024 or ....)
2. the file is missing in the texture directory.
There is yet another reason that would also correspond to some testers encountering issues and others not. That condition would be name conflicts.

Because of the virtual file system MSFS is not able to prioritize name matching conflicts to their relevant packages and instead loads the first example encountered that does not necessarily match the file path it had been called from.

Therefore, if a texture named “tarmac” is called, the sim will render the first example of “tarmac.dds.png” it encounters.

The solution is to always use unique names.
 
Messages
253
Country
germany
There is yet another reason that would also correspond to some testers encountering issues and others not. That condition would be name conflicts.

Because of the virtual file system MSFS is not able to prioritize name matching conflicts to their relevant packages and instead loads the first example encountered that does not necessarily match the file path it had been called from.

Therefore, if a texture named “tarmac” is called, the sim will render the first example of “tarmac.dds.png” it encounters.

The solution is to always use unique names.
I thought naming issues are only when using data from a common directory, but it sound reasonable so we do have no 3.
 
Messages
26
Country
us-ohio
For the most part it is as =rk= mentioned. It is definitely a conflict of naming conventions. Renaming our materialLib to be uniquely associated with our packages fixes the issue. Working with the user that had an issue with one of my airports showed that a payware (of all "people") did not have a unique name for their materialLib....not to say they were at fault....I was just as guilty.....and was conflicting. It just made it important for me not to rely on someone else's to do their due dilagence and I must do my own....as should all of us. Now....I need to figure out how to rename my materialLib in a manner to not have to redo my entire airport textures. Simple renaming the folder and rebuilding doesn't do it.....Yikes.
 
Top