• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Missing textures in MSFS

Messages
5
Country
spain
Hi all

I am just trying to get to know the workflow to get an object from 3dsMax2020 into MSFS.

I have created a simple cube with a concrete texture (512x512). I have used the babylon exporter to export the model. Paths are:
Model ...\HOH\PackageSources\scenery\modelLib\Cube.gltf
Textures ...\HOH\PackageSources\scenery\modelLib\textures\
I also copy the .xml file from the "Samples" folder and create a new guid (guidcreator website).

When building the new package I get the following error:
glTFLister | Model texture not found in the texture directories: 'TESTBOX01_TEXTURE.PNG' - for model: 'C:\Users\Stefan\Desktop\shortcuts\MSFS2020\Projects\HOH\PackageSources\scenery\modelLib\Cube.gltf'

Also, when I run the "Export and run" option in Babylon I get an error "/images/0/uri: Failed to load 'testbox01_texture.png': 404 Not Found"

I have tried following several youtube tutorials, unfortunately they all use Blender.
I have also tried different paths for the texture (texture in "scenery folder for example") but so far no luck.

It is probably something small I am missing (as always).

The cube shows up and I can place it, but it has no textures.

Any help is welcome.

Many thanks

stefan
 
"Textures ...\HOH\PackageSources\scenery\modelLib\textures\"

Looks like the "textures" folder is the problem, should be "texture".
 
Thanks for the quick reply :)

I have tried what you said, but no luck.

The weird thing is, I get no error warnings and when I check in the package the textures are there together with a png.dds file.
I wonder if it is a simple setting somewhere?

I create a UV map and then put that onto the model using MSFS material. I haven't changed any of the settings since it is a simple texture (.png format 512x512).
Here is what I do, together with the result.

Maybe I am missing a tick somewhere?

Thank you again and kind regards

stefan
 

Attachments

  • 3dsmax.jpg
    3dsmax.jpg
    276.8 KB · Views: 157
  • editor.jpg
    editor.jpg
    709.9 KB · Views: 160
  • export.jpg
    export.jpg
    328 KB · Views: 173
A few things I stumbled upon:
- With my setup the images have to be divided by 8 both sides (not 2 or 4 as stated in other forums). So 1824x600 would work, 1820x600 wouldn't. But it would show an error in the console.
- UV map on top of an object does not work for me in some cases. So simple box -> texture.
- And the same texture in 2 different slots does not work for me either. I need to do a copy. It generates a .PNG.DDS file that opens with an error in gimp and does not have a preview
- size does not seem to be an issue. I accidentally put a 80+MB texture on a model. It still worked

In your case I would try the path .....PackageSource\modelLib\Cube\texture
I have to manually enter the texture path. Otherwise Babylon throws an error.

Hope this will help someone out there. :)
 
Back
Top