• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS model files are driving me crazy

Messages
125
Country
us-louisiana
I am having such a time with the model files. I copy the files to the modellib folder as requested and they load fine in there. I can go and place it in the editor I see the placeholder for it and can click on it and edit its setting like normal and save and build it with no errors. Run it in the sim and it is not there for some reason. I follow the persons instructions to the tee. Here they are: "
How to use :

You can not JUST place the folders under your community folder like a standard mod, this asset is for modders

Place the content of the ZIP into the project you're working on. Final path should looks like "(...)YourProject\PackageSources\modelLib\GBZH35_Helipad_Circle/" (for example)
Do not modify any name in the files
If you don't see the pads/textures on your project, TRIPPLE check the names for ALL xml, bin, textures, etc.. this is 99% of the issues :)
Read the comments, it can help"

I really need to get this working if someone would try to help me.
thx
 
Messages
71
Country
unitedstates
First thing is to open the console window in the sim Windows menu, clear the contents, then open your project to confirm that the sim is finding your model files and check for compile errors.
 
Messages
71
Country
unitedstates
Dev Mode in the sim, not the Scenery Editor.

For the sim to be able to recognize any model, the gltf ("model file") must be compiled into a bgl. The Build function in Dev Mode is where this usually occurs. (This undoubtedly calls a program in the SDK that can also be called from command line, but that is probably more complex that you would like.)

Either use Dev Mode to compile/build PackageSources into a Package, which is then installed into the Community folder, or
use Dev Mode to edit the project and build the PackageSources into a Package which can be used in Dev Mode without installing to community.
 
Messages
125
Country
us-louisiana
Well, thanks for your input, but I use ADE so any advice you give me will not help me. as far as the sim editor.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
33,809
Country
unitedkingdom
You can not JUST place the folders under your community folder like a standard mod, this asset is for modders

Place the content of the ZIP into the project you're working on. Final path should looks like "(...)YourProject\PackageSources\modelLib\GBZH35_Helipad_Circle/" (for example)
Do not modify any name in the files
If you don't see the pads/textures on your project, TRIPPLE check the names for ALL xml, bin, textures, etc.. this is 99% of the issues :)
Read the comments, it can help"

OK - I am sorry if I have said this already but Section 16 of the pdf notes which are in the zip file along with the ade installer covers adding user models. Can you confirm that you have tried to follow that section?
 
Top