FSXA ModelConverterX .mdl saving as 0kb

Jaeyo

Resource contributor
My FSX won't open the model file. Looking at this the model file is 0kb. It shouldn't be.

Why is this?
 

Jaeyo

Resource contributor
These are the error logs:
10:21 XtoMDL Information CRASHTREE no granularity specified
10:21 XtoMDL Information CRASHTREE completed in 00:00:00.0425312
10:21 XtoMDL Information error : Vertex list has too many vertices (74329), max allowed: 65535
10:21 XtoMDL Information error : Attempting to add an invalid vertex buffer!
10:21 XtoMDL Information error : Vertex list failed allocating. Most likely exceeds the 65535 limit.
10:21 XtoMDL Information error : Failed to resolve vertex: Vert1997
10:21 XtoMDL Information Usage: XToMDL.exe /KEEP /NOGUI /BATCH /NOCRASH /BMP2DDS /XMLSAMPLE /XANIM /DICT:DictFileName /OUT:OutfileName Filename.X
 

tgibson

Resource contributor
Hi,

Note that you can use the same texture, but the parts using that texture must be split into using two or more materials, with a tiny difference in one of the material settings.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Note that this splitting is something that MCX should do by itself, so apparently that is not the case here. Are you using the latest development release?
 
Hi,

Note that you can use the same texture, but the parts using that texture must be split into using two or more materials, with a tiny difference in one of the material settings.
I knew this rule when you hit the limit but it has not happened in so long i forgot you need a alteration in the settings. Thanks for mentioning that.
 
Top