• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS MSFS Toolkit by Nool Aerosystems

Messages
425
Country
us-ohio
as I said: start with dot backslash to indicate you want to run the tool from the current directory:
Code:
.\msfs ....

or alternatively enter the whole path to the tool
Code:
c:\nool\msfs ...
sorry, im kinda new at typing code to run things, but this is what i get when i try those options

Screenshot_7.jpg
 
Messages
102
Country
italy
In the installation instructions there is no mention of Windows Powershell or cmd ... there is a dedicated .bat file.

Installation​

Standard installation​

  1. Download the toolkit from Releases.
  2. Extract contents of the downloaded ZIP file.
  3. Click on msfs.bat to launch the shell.
  4. (First run only.) Follow on-screen instructions to download and install OSGeo4W components required by the toolkit.
Now you can type the name of any tool into the console, eg msfs aerial to use aerial imagery tool.

Installation
 
Messages
102
Country
italy
Apparently my version 0.52 doesn't want to know that it works. It opens correctly and then with the -elev tool does not compile.

It is happening to me too after I loaded a project with its *.xml (done with version 0.51 because with version 0.52 I can't get the * .xml), in MSFS Current Version: 1.19.9.0 (SDK 0.14.1) and saved it with some changes it is not compiled

ERROR: 4, 786465, Too many levels of recursion. Stack overflow.

? false returned by Command = BuildPackages Comment = Rebuild the packages whose name correspond to the given filter, and for the given project (default fs-project.xml) NbParam = 2 Line = BuildPackages italiancharterteam-ao-dem * "J: / MSFS_Dev / AO_DEM / italiancharterteam-ao-dem.xml "" J: / MSFS_Dev / AO_DEM "1 1 1
[Packages] Package content mounted: 'package: // edition / italiancharterteam-ao-dem' @ 'J: \ MSFS_Dev \ AO_DEM \ Output \ italiancharterteam-ao-dem'
[Packages] Package content unmounted: 'package: // edition / italiancharterteam-ao-dem' @ 'J: \ MSFS_Dev \ AO_DEM \ Output \ italiancharterteam-ao-dem'
Compiling BGL from file s10e016.xml ...
INTERNAL COMPILER ERROR: # C2006: Parse failed (0x80004005)
INTERNAL COMPILER ERROR: # C2034: XML Parse Fatal Error (line, column, error)
INTERNAL COMPILER ERROR: # C2430: Unrecoverable error parsing XML!
PackageBuilder | Building assets for the package italiancharterteam-ao-dem ...
PackageBuilder | Done, 3 asset groups registered.
PackageBuilder | Finished, 1 skipped, 0 done and 1 failed, took 9s206ms.


Also making the comparison with version 0.51( the info is displayed correctly) with the command: msfs elev -help, while with version 0.52 is it has this:

=======================================================================================================================
MSFS TOOLKIT SHELL NOOL AEROSYSTEMS OÜ
Welcome https://www.nool.ee/
=======================================================================================================================

Available tools:
* aerial
* elev
* grid
* meta
* project
* shpattr
* shpelev
* shpuuid
* watermask

Usage: msfs [tool]
J:\msfs-toolkit-0.52>msfs elev -help
Traceback (most recent call last):
File "J:\msfs-toolkit-0.52\msfs_elev.py", line 43, in <module>
import noolaero.util as util
File "J:\msfs-toolkit-0.52\noolaero\util.py", line 7, in <module>
os.add_dll_directory(pathlib.Path(os.environ["osgeo_root"]) / "bin")
NameError: name 'pathlib' is not defined

J:\msfs-toolkit-0.52>
 
Messages
8
Country
unitedstates
Good day everyone. I am a complete amateur in the world of scenery creation. I've been programming my entire life and have forgotten more languages than I currently know. I have been playing around with my home airport, KBWI as MSFS decided to base the one in the sim on images taken sometime prior to 2014. KBWI completed major changes to the runways, taxiways, and terminals in 2014. Unfortunately, the images used in the sim were taken while one of the primary runways were closed, so none of the SIDs or STARs would show up in MSFS (because of the missing runway). What started off as a simple mission to add a missing runway has turned into a full blown renovation. I've made fantastic progress. I've got a projected mesh covering the airport that shows the current layout. I also have the CGL file aerial scenery with the same image that shows up when photogrammetry and Bing data are turned off (which was my 1st attempt to cover the base image, and which lead to my discovery of projected meshes). I've got several aprons done, all of the taxiways done, some runway signage done, some terminal area lighting added, and 99% of the gates added and connected to the taxiways (I do have an issue with these - I'll ask for help with that in a new thread). And from the very beginning, I have been religiously grouping everything, so the project is well organized and easy to work with. All good so far. So good, that I might share it when it is done. I have a shot at making this a worthy offering. But for now, I just want it working for me.

My dilema, and why am I posting in this thread is that I started off out of order. My next mission is to add a proper elevation profile, but it appears as though I skipped a critical step in the process early on. I captured the images I wanted for the aerial package from Google Earth and used Gimp to cut out the airport background image I wanted, making the rest of the background transparent. I opened up this shaped .PNG file and used QGis to georeference it and save it as a Geotiff. This worked great, but now I realize that I do not have a shapefile to use with the Nool msfs -border option, and I do not know the extents to input as arguments to the -bounds option when I try to use the Nool tools.

If I right click on the Geotiff I see the min and max long and lat extents, but they are in meters I believe, and I have no idea if I can convert them or how to convert them. Is there an easy way to take a shaped Geotiff image and run it through something that will generate a shapefile conforming to the perimeter of the image? I have downloaded the Lidar and DEM data for the airport already. Is there a way for me to add the elevation data to my airport without having a shapefile defining the shape of my projected mesh and aerial imagery to make sure that they all line up? Am I overthinking this and I should just forget about the mesh and aerial imagery I already have and move forward with adding the elevation info without regard to them?

Thank you! Y'all have taught me a ton. I've been reading threads here for a couple of years now. This is a great forum.

Here's what I've got so far. Compare it to the default KBWI. I think it's much better. Sorry about the haze, I forgot so set the sim to clear skies. One day, I'll take a crack at color matching the Geotiff ;) (can I do that in Gimp without messing up the Geo information?)

bwi.jpg
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
4,776
Country
us-wisconsin
I think Paint.net can manipulate colors and can export the geotiff without loosing information (make a backup copy first).

Attached is a shapefile of the area, you can use QGIS to change it if it's not what you want.
 

Attachments

  • KBWIShapefile.zip
    1.9 KB · Views: 8
Messages
8
Country
unitedstates
Thank you very much, Dick. I had tried without success editing shapefiles in QGIS before I posted that question. But since you provided that shapefile and said I should be able to edit it, I went back to the books and spent a little more time with the QGIS help files. You put me on the right path. In the end, I loaded up an updated copy of the geotiff image that I used to create the aerial CGLs in QGIS and added a new shapefile layer above it and then created my own that matched it perfectly. My concerns were that if I wanted to use a CGL image and add elevation data that I needed to use the same exact shapefile for both, and that I was up the creek without a paddle since I had already added the projected mesh without it. Now I understand that was not the case.

I was successful in adding 1m lidar from the USGS TNM web page to BWI airport. The results are even better than I had hoped. The contours match my projected mesh perfectly. The Nool elevation tool made the process ridiculously easy. What an excellent tool. I will certainly be giving them an honorable mention if my project ever gets distributed.

The new geotiff that I used to create my shapefile has about 80 more GCP points than the original one and matches the surroundings much more precisely around the edges. It's also feathered on the edges so it should blend in much better as well. My next step will be to use Nool scenery next to replace the old aerial scenery CGL I'm currently using with that newer geotiff. I did it with a tool called bing2tiles the 1st time around. The final step will be to update my projected mesh to use that same image and Bob will be my uncle from a terrain perspective. The part that I was most worried about is now complete to a more than satisfactory level.

My goal was to produce a commercial grade BWI airport for my own personal use. Well, I've got the terrain in the bag (and yeah, I'll try that color matching thing sometime soon), most of the gates added, nearly all of the taxiways added, apron lighting, and a few other odds and ends are done. I have a basic terminal building model in Blender that fits perfectly in place of the default that I will finish in the next couple of months. My airport really is going to happen. ;)

Thanks Nool!
 
Last edited:
Messages
773
Country
us-northcarolina
Well... I got the thing to compile...

This is what I ended up with.

For what it's worth, I downloaded lidar data from USGS and used globalmapper to convert it to a geoTIFF.

12.JPG
 
Messages
773
Country
us-northcarolina
Okay, to back up a bit, I first downloaded the latest release. It doesn't work. Click on the .bat file and it opens, and it closes immediately upon pressing any key. So I went after the previous version.

When I use version 0.52, it was giving me an error saying "ValueError: could not convert string to float: 1600.81M" 1600.81 meters being the airport's runway length. I put my terrain sources in with an already existing ADE project, I didn't create it from scratch in the simulator. I figured the "M" in that value was causing the issue so I just casually took it out. That gets it to compile, but then it looks like the giant hole above. Going into the airport .xml where the changes were made, I can see the elevation values are FAR too low.

I'm using USGS DEM's based on LIDAR data.
 
Messages
773
Country
us-northcarolina
Okay, I fixed it. I'm an idiot. Way back at the beginning of the process, I didn't export my geoTIFF as an elevation grid. D'oh!

That being said... WOW!!!!! This thing is AWESOME! It achieves in a few minutes what I've never been able to hand craft myself in any other sim as far as terrain goes.

12.JPG
 
Top