Multiple AI in one parking spot

I've recently made an airport from scratch. It is a fictional airport. I have no faults in the fault finder of ADE but instead of using each parking spot provided, my airlines will park "through" each other at several single parking spots. However if I change the date so that all aircraft are on the field, the parking is fine and every gate is filled with a single ship. The radiuses are correct for the aircraft visiting. There are no overlapping spots. I have no clue why this is happening nor how to fix it. Only thing I can think of is P3D possibly has a limit of certain aircraft or limit of certain airlines that can land at one time? I am using P3D v4.5. Will supply my file upon request.
 
This can happen if an AI aircraft, having landed, doesn't pass through an hold-short node on its way from the runway to a parking spot.
 
This can happen if an AI aircraft, having landed, doesn't pass through an hold-short node on its way from the runway to a parking spot.
I will try that..I haven't added any holds yet. I didn't think that would cause such erratic behavior. I will report back
 
This can happen if an AI aircraft, having landed, doesn't pass through an hold-short node on its way from the runway to a parking spot.
I seem to remember also that if the "Hold-shorts" are not 'in the correct direction', i.e. solid line first as you approach the runway, then a similar situation can occur.
 
I seem to remember also that if the "Hold-shorts" are not 'in the correct direction', i.e. solid line first as you approach the runway, then a similar situation can occur.
No, the direction is purely visual.
 
TNTom when an AI aircraft leaves the runway and crosses the hold-short that is when it's parking spot is assigned.
Ed
 
odd. I placed some holds on the runway exits, now my ai go past the hold then stop until they disappear. I feel I'm missing something simple.
 
if the AI have got to the hold short then there's possibly a break in the taxiway/path to the parking spots
have you run Fault finder
 

Leo2789

Resource contributor
odd. I placed some holds on the runway exits, now my ai go past the hold then stop until they disappear. I feel I'm missing something simple.
Hey!
Having added Hold short nodes, the reason the plane disappears now is either because of a break in the taxi path to the parking spots ( as @glottis mentioned), or because your parking spots are all full when that plane lands!
Make sure neither is happening and you should see your AI behaving correctly!
 
LOL!!! I forgot i was supposed to do this morning..................
the only other thing i can think of is the "Time out", if there's a lot of traffic using the taxiway for takeoff that the aircraft that's vacating the runway want's to use, it will just sit there
we may need his ad4 file, i don't have P3D so i wont be of much help
 
I've run fault finder several times and it does not find anything. I've gone over every single taxiway and I find no broken links. Some of them are long so I had to make multiple links on the grid before I drew the taxiway to ensure they were straight. Maybe each taxiway only needs two end points? I've deleted a runway, parking kind of changed its sequence but still double parking. Gate sequence was left in order of gate placement for ease of testing, but the sequence doesn't seem to matter right now. Couple things I will mention, there is a LOT of traffic coming in at certain times, but no departures. Maybe I need to spread the AI arrival times out? I'm open to any more suggestions and I will try and tweak a bit more and experiment but I'm getting close to just finding a stock airport somewhere that can handle a lot of traffic. Basically this airport is for storage. The aircraft sit for two months before departing. May be a dumb idea and kind of boring, but I thought I would give it a shot.
 

Leo2789

Resource contributor
I've run fault finder several times and it does not find anything. I've gone over every single taxiway and I find no broken links. Some of them are long so I had to make multiple links on the grid before I drew the taxiway to ensure they were straight. Maybe each taxiway only needs two end points? I've deleted a runway, parking kind of changed its sequence but still double parking. Gate sequence was left in order of gate placement for ease of testing, but the sequence doesn't seem to matter right now. Couple things I will mention, there is a LOT of traffic coming in at certain times, but no departures. Maybe I need to spread the AI arrival times out? I'm open to any more suggestions and I will try and tweak a bit more and experiment but I'm getting close to just finding a stock airport somewhere that can handle a lot of traffic. Basically this airport is for storage. The aircraft sit for two months before departing. May be a dumb idea and kind of boring, but I thought I would give it a shot.
Hey Tom!

I think its time you shared the files of the airport that's giving you this problem here, so someone else could check it out and see if something sticks out that you might have missed or are unaware that is a problem? :)
Because if there are indeed no broken taxiways then AI parking on the same gate shouldn't happen...
I can't be that person unfortunately as I'm not familiar with P3D development :confused:
Don't give up! No FS related idea is dumb or boring imo if you got excited to do it in the first place! Ultimately even those that make sceneries or aircraft for FS and share them with the world, do it for their own enjoyment in the first place! :)
 
Here are my files. I fiddled with it some more but to no avail. I removed the holds for 18L and 18R so the AI would not freeze after passing through. Still no luck. I'm sure the solution is simple, I just need some other eyes on it I guess. The purpose of this airport is kind of my own imagination. I have painted aircraft for each of the teams of all 4 major US sports leagues. With flight plans being able to be written for eight weeks, I write traffic files for the teams schedules. Since none of them are in play now due to the covid-19, the aircraft have to be stored/cleaned/disinfected. The airport is located in rural west Tennessee, fairly close to my home airport. I'd appreciate any advice, tweaks, etc., that you folks can give me. You have been much more helpful than another forum I asked for advice from.
 

Attachments

Top