• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSX Must have a valid vegetation GUID set

I am new to annotator having read some tutorials and documentation but still having some basic problems with it.

I loaded the Autogen Descriptions into the AG Configuration Editor. There I selected AG Bush General and opened the tree down to the one I desired "Bush General 8ft", more detailed than that was not possible so the selection was made in the Editor.

Then In the Annotator I loaded the BGL that contains the photoreal scenery tile. I want to use it to place lines of trees with the annotator.

In the Control Strip (Annotator) I clicked on the Vegetation (V) button. Since I already selected on the Editor the type of bush I wanted, I proceeded to click on the Set GUID button that is next to the Vegetation (V) button. At this point -in spite of having made my selection- it still shows GUID NULL.

When I click on the photoreal tile I get "Must have a valid vegetation GUID set" error. It makes sense because the control strip shows GUID NULL for the vegation. What I don't understand is WHY it doesn't take the GUID if I have already selected the type of tree in the configuration editor?

In the attached image you can see I have made the selection(s) in the Autogen Configuration Editor (A) and still no GUID with the proper configuraiton in the Annotator (B). I want to pin those trees to the photorealistic tile shown in C.


  • AutogenAnnotatorQuestion.jpg
    100.4 KB · Views: 2,400
As it turns out, if you select the most specific item from the selection tree (say, Bushes General ft) such as those listed in the selection tree with a small cone icon on the left, it will NOT set the Guid.

If on the other hand, you select a group/category (Ag Bushes General) rather than the item that is expanded below the category, only THEN you can Set GUID.

Strange but then again I am not very impressed with the programmer than wrote the Annotator.
Hey, it has been a lot of years after you posted this. If you read this, you have to know that you solved my problem! Thank you a lot! It feels like I have been searching for this awnser all over the internet:)