FSX My FSX object library is broken

To begin with, I have not done any FS2004 design. Having said that, some years ago I created a bunch of FSX sceneries and with that my own Library with the Library Creator X (2.0.4) and it worked fine, the models were all FSX models (I repeat).

Today I tried to read my library and it showed all my objects in RED, now all the objects have their GUID empty and if I try to re-insert it with the same model it says it is an FS2004 model or so when it is really an FSX model (I repeat I have NEVER created FS9 models and I used them before in FSX in my FSX lib).

So, why is that? How can I fix that? If I need to re-add them I will need to preserve the GUID to the one I had registered before or all my sceneries will be broken and will be a pain to go through all the objects.
 
Hi Emilio:

Until Arno has some time to reply, just an idea:

Load your scenery object library BGL into Arno's ModelConverterX (aka "MCX") and examine the GUID format for each MDL to see whether it is the FS9 or FSX alpha-numeric format.

You may opt to utilize the "Batch Convert" functions as needed:

http://www.fsdeveloper.com/wiki/index.php?title=ModelConverterX#Batch_convert


Hope this helps ! :)

GaryGB


PS: I linked to this same info in my reply to your other thread ...here:

http://www.fsdeveloper.com/forum/threads/assign-a-custom-guid-to-the-model.435685/
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

If they are shown in red the mdl files are not found. Check your xml file, maybe it uses absolute paths that are not valid anymore.

Or create a new library with your mdl files. For FSX the guids are in the mdl, so they won't change.
 
Top