• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v4 Need help for a string in xml radio altimeter gauge

Messages
15
Country
mexico
Hello, can someone please help me to make this string right, I have tried everything I know but I cant seem to get the string to work

<String>%((A:RADIO HEIGHT,FEET) ft 2500 <)%{if}((A:RADIO HEIGHT,FEET))%!04d!%{else}OFF%{end}</String>

What I want to accomplish is to set it OFF after 2500 feet AGL
Thanks in advance :)
 
Messages
946
Country
australia
You have "ft" between ",FEET)" and "2500". Try removing it because it shouldn't be there.

Also, make sure you are using
Code:
&lt;
and not < in your code. It may be that you are but copying your code to the forum has changed it to <. The reason you need to use the lt code is because < is a recognised character in XML. Every element starts with < so you cannot use that character for any other purpose (such as maths).
 
Last edited:
Messages
15
Country
mexico
You have "ft" between ",FEET)" and "2500". Try removing it because it shouldn't be there.

Also, make sure you are using
Code:
&lt;
and not < in your code. It may be that you are but copying your code to the forum has changed it to <. The reason you need to use the lt code is because < is a recognised character in XML. Every element starts with < so you cannot use that character for any other purpose (such as maths).
Hello, Thanks a lot for your help, have been trying to figure it out for the last couple of days but now is working

This is what worked:

<String>%((A:RADIO HEIGHT,FEET) 2500 &lt; )%{if}%((A:RADIO HEIGHT,FEET))%!4d!%{else}OFF%{end}</String>

:)
 
Top