No SP2/XPack SDK in FSX Acceleration disk or in either FSX Gold’s disk 1 or disk 2

#1
Hi,

I own FSX Acceleration and I am installing SDK from it:

I first installed SDK from my FSX Gold Edition’s SDK sub-folder in disk 1 -using the setup.exe file, and then installed SDK SP1 from my Acceleration disk’s SDK\SP1a\ subfolder -using fsx_sdk_sp1a.exe (dated 09/26/2007); but I am unable to also install SP2/Xpack SDK because it and its installer sdk.msl (dated 10/06/2007) are not included in my Acceleration disk or in either FSX Gold’s disk 1 or disk 2.

I purchased FSX Gold Edition (which includes Acceleration) in October or November 2016.

If you know how, please let me know how can I get the SP2/Xpack SDK and its installer sdk.msl (dated 10/06/2007).

I will appreciate your help very much.

Best regards,

Luis
 
#3
Hi Pyscen,

Thank you very much.

I followed the directions in that document.

My problem is that SP2 does not show in my FSX Acceleration disk as it neither is in my FSX disk 1 or disk 2.

These 3 disks are included in FSX Gold Edition which I purchased in 2016. Both SDK and SP1 are included in my disk 1; but SP2, which is supposed to be found in my Acceleration disk, does not show in any one of the 3 disks.

I am hoping I can locate the SP2 somewhere else and be able to use it.

I will appreciate any help very much.

Best regards,

Luis

PS: If I am unable to locate and install SP2, I hope that will not cause much trouble using ADE 175.
 

Pyscen

Resource contributor
#4
Hello..

According to the location that I gave you....

FSX Acceleration Pack OR FSX Gold Pack users
To install the SDK for FSX Acceleration Pack OR FSX Gold Pack:

  1. Install the RTM SDK from FSX Deluxe Edition disk 1, (see 3.1.1 FSX Deluxe RTM users instructions above).
  2. Insert your Acceleration Pack DVD.
  3. Browse to the subfolder called SDK\SP1a\
  4. Install the SDK SP1A from there using fsx_sdk_sp1a.exe, (dated 26/09/2007, size 165,569KB).
  5. Browse to the folder called SDK\
  6. Install the Acceleration SP2/XPack SDK using sdk.msi, (dated 06/10/2007, size 216,929KB).
According to step 6) should be located on the Acceleration SP2/XPack SDK Disc and the filename is sdk.msi.
 
#5
Hi Doug,
I am still confused:
My FSX Disk 1 contains SDK (and I installed SDK from it in my PC) and my Acceleration Disk contains SP1 (and I installed SP1 from it in my PC), but SP2 is not in my Acceleration FSX Disk, neither in FSX Disk 1 or Disk 2.
Please see the picture that I have attached which shows the SDK-related contents in my Acceleration Disk.
>>>
Per the directions on https://www.fsdeveloper.com/wiki/index.php?title=SDK_Installation_(FSX) :
“FSX Acceleration Pack OR FSX Gold Pack users
To install the SDK for FSX Acceleration Pack OR FSX Gold Pack:
Install the RTM SDK from FSX Deluxe Edition disk 1, (see 3.1.1 FSX Deluxe RTM users instructions above)”,
the first thing I did was to install SDK from Disk 1:
“Installing SDK
3.1.1:
FSX Deluxe RTM users
To install the SDK for FSX RTM:
1. FSX must not be running.
2. Browse the FSX Deluxe Edition disk 1
3. Open the SDK sub-folder
4. Double-click the setup.exe
5. Tell it where to install
Default installation location is C:\Program Files\Microsoft Games\Microsoft Flight Simulator X SDK”
Then, after installing SDK, I went on to install SP1 -continuing following the directions in https://www.fsdeveloper.com/wiki/index.php?title=SDK_Installation_(FSX)
which you copied me in your previous post:
1. Insert your Acceleration Pack DVD.
2. Browse to the subfolder called SDK\SP1a\
3. Install the SDK SP1A from there using fsx_sdk_sp1a.exe, (dated 26/09/2007, size 165,569KB).
Up to here, I had no problem: I had installed SDK and SP1 too, but then I could not install SP2 as indicated in the last two steps -4 and 5:
4. Browse to the folder called SDK\
5. Install the Acceleration SP2/XPack SDK using sdk.msi, (dated 06/10/2007, size 216,929KB).
I could not do steps 4 and 5, because none of my 3 disks include SP2 and its installler.
This is my problem.
What can I do?
FSX Acceleration Disk’s SDK contents.png
 

Pyscen

Resource contributor
#9
Hello....

Yes... it appears that it is SP2. It's been to long since I've had to install the SDK for FSX. Therefore, I want to say that it should work, but if it doesn't, you will only have to reinstall the SDK and not the FSX all over again.
 
Top