• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Object Placer and FSX

I find I can place FS9 default 3d objects with Object Placer.

How can I place FSX default 3d objects with Object Placer; for example those shown in the "sceneobjects" download.

It looks like I can use the Object Placement Tool in the Missions SDK to accomplish what I want but I am darned if I can get a Tools menu on the main menu bar in FSX when I try to activate the Object Placement Tool; I've followed the help/tutorial threads etc, and tried a copy and paste splice from the dll.xml sample in the Missions SDK, tried several FSX start up conditions with default or addon sceneries - still no Tools menu.

The SDK is installed in its default location of Microsoft Games\ Flight Simulator FSX etc in the C: partition on my first drive. FSX is in the G:partition on a second drive.

Any ideas of what is wrong?


My System:

Intel Core2 Duo E6400
Gigabyte GA 965G DS3 mobo
Sapphire ATI Radeon X1950XT video card PCI-e 512MB
2GB Transcend 800Mhz DDR2 RAM
Maxtor 80GB 7200rpm hard drive
Maxtor 200GB 7200rpm hard drive
Western Digital 250GB 7200rpm hard drive
Creative Sound Blaster Live! with latest drivers
NEC FE950+ crt monitor
CHProducts USB yoke and pedals
Windows XP Home edition with SP2
DirectX 9.0(c)
Cooler Master 600W power supply
Five case fans – four suck, one blow
Hi Nigel,

ObPlacer XML is only for Fs2004 indeed, although you might be able to get some FsX objects in if you tweak the configuration XML files.

But I think the Object Placement Tool of MS is easier to use in that case. I already replied to your question about getting it working on AvSim. Simply said, make sure that it is active in the XML file (by default the Disabled attribute is set to TRUE) and double check your paths.
I have posted this at the AVSIM scenery design forum as well

Hi Arno

Thx for your response - yes I think I have done everything according to the book and my ddl.xml file contents are below.

I have just gone through a hard drive (c:) failure, followed by a motherboard failure. This meant a new motherboard, CPU, RAM and video card. My dealer managed to recover all my Windows XP files and I found I had to re-activate FSX, but basically the computer and FSX have been operating well since. I wondered whether FSX had lost contact with the registry so I have just put the FSX discs in and done a repair. That has not resolved the Tool menu not showing.

I also activated TrafficToolBox and VisualEffects to see whether they would bring in the Tools menu - no luck. The FSUIPC4 module is showing okay in the Addon menu.

It is a puzzlement.


ddl.xml contents:

<?xml version="1.0" encoding="Windows-1252" ?>
- <SimBase.Document Type="Launch" version="1,0">
- <Launch.Addon>
<Name>Object Placement Tool</Name>
<Path>..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll</Path>
- <Launch.Addon>
<Name>Traffic Toolbox</Name>
<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK\traffictoolbox.dll</Path>
- <Launch.Addon>
<Name>Visual Effects Tool</Name>
<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll</Path>
- <Launch.Addon>
<Name>FSUIPC 4</Name>
Hi Nigel,

I think you said you had FsX on the F drive and the SDKs on the C drive. In that case the relative paths listsed now will not work I think. Try to put in the full paths in the Path command (so the full C:\Program Files\.....).
Hi Arno

I just put in the complete path as recommended by Tim over at AVSIM and that did the trick. Thx for your help for the umpteenth time!

Hi Lance,

1.) Has there been a change between FS9 and FSX where these built building would no longer be possible, ie differences in the texture sheets that are used or any coding differences?

I think there are a few new texture sheets and some of the texture coordinates might have changed. So that would have to be updated to get it working.

2.) If ObPlacer for FS9 doesn't work forward, might there be the chance of a subset of features from ObPlacer that were made to work within FSX, so that the ability to create and place buildings were possible?

Yes, that is something I am thinking about. Most tools don't have the dynamic preview for generic buildings. I think you are right that this is useful, so maybe I can release that part as standalone or update the current ObPlacer XML a bit so it is working again. I would have to think about that a bit more.