• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Obplacer_xml First Report

Messages
1,484
Arno...here's a beta report. First thanks for such an awesome utility. This is the tool I've been most hoping for.

A couple bugs are keeping it from working for me, but that's to be expected.

I have two ideas for improvement, but first I'll discuss the fatal flaw!

After getting the ocx file installed, everthing appeared to work as expected. I loaded a file I've been working on, successfully deleted a mdl, and then proceeded to add 11 mdls to my list, and place them. At that point I clicked "save xml". I got the error message shown in the attacked pic and the application froze.. I had to use the alt-cntrl-delete to end the application.

I then looked at my file (I had backed it up prior to starting of course!). The xml appeared to not include any of my additions, which i'd expected, but the white space was entirely reformated, and now the file no longer will parse manually. Somehow the process of opening the file disturbed the format of the xml that was initially there. And you know how fussy xml is about format.

I tried to re start obplacer and re-open that file, but now it claims a runtime error...pic 2 if this board allows 2, otherwise I'll follow this message with pic 2.

So that's the bad bug.


Now...enhancement ideas

I'd enjoy being able to populate my mdl list with a multiple selection.
I'd rather the curser not point at the top line of my object list upon placing a new model. It would be better to have it point at the mdl just entered.


Thanks again for your efforts! This is surely the tool of choice.

Best,

Bob Bernstein
 
Last edited:
btw, thought I should mention that my xml file that got messed up had some initial entries that weren't standard mdl placement items. I'd started that file with some exclude areas, then a trigger, and a windsock. Perhaps that confused obplacer.

Bob
 
Hi Bob,

Can you send me that XML file? The normal XML save procedure does not give a very readable XML file (all commands on one line). Therefore I run my own subroutine on it to make readable code out if it again. I think that code hit something it was not anticipating and therefore gave you the bug.

For the ideas. Adding multiple MDLs at the same time. Humm, something like Library Creator XML thus where you can add an entire folder?

For the location in the list that is a good point. I had noticed that before. Will take a look at it.
 
Thanks got it!

Time to move back behind my laptop now and try to find those bugs :D.
 
Yes, it was what I thought. I have updating the saving routine and your file works OK now. The saved XML file has also an increased readability in the new version.
 
Back
Top