Placing Objects/Buildings with Whisplacer

#1
Hi folks,

I'm just in a process with the correction of an original FSX aiport.

I've to move a couple of buildings in LAT and LON.
Some of them are library objects, others are generic buildings.

As recommended by other users I've tried Whisplacer.
But it doesn't seem to work satisfactory:

My Library Objects (original FSX) are unknown to Whisplacer, despite it populated the database after setup.
So Whisplacer shows only a cross at the reference point of the object.
The objects were not shown in FSX with live preview.

Generics Buildings were shown by Whisplacer with their length and width but are not visible in live preview.

Nevertheless a connection between FSX and Whisplcer is established.


So for the moment I have to move each building step by step and restart FSX inbetween to see the result.
That's a really annoying process!

Does anybody have a better solution?


Michael
 
#2
I've to move a couple of buildings in LAT and LON.
Some of them are library objects, others are generic buildings.

As recommended by other users I've tried Whisplacer.
But it doesn't seem to work satisfactory:

My Library Objects (original FSX) are unknown to Whisplacer, despite it populated the database after setup.
So Whisplacer shows only a cross at the reference point of the object.
The objects were not shown in FSX with live preview.
Default airports often contain custom buildings whose models are located in OBX*.BGL. Whisplacer doesn't "know" them because it preferable not to use them outside their area.
What is the label displayed near the building ? if it looks like "Autogenerated: {xxx}" then it's one of them.
However, if the label is "UNKNOWN" then you definitively have a problem with your library database. try deleting the file "library.db" and restart import process.
If you see a name but no images, then check you've downloaded the thumbnails archive (70 mb) and extracted it to the thumbnails folder. Also check that you did not disabled the thumbnail display (in the appropriate menu)



Generics Buildings were shown by Whisplacer with their length and width but are not visible in live preview.
Only library objects are visible in live preview. Managing other objects, like generic buildings is far beyond what FS publicly allows to do.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#3
Edit: This is a reply on Doug's message, but because we fixed the time of the server it does appear above it.

And because they are included in the same BGL file as the placement they are geo-locked to that area. So that is the reason (I guess) that Whisplacer does not show them to you, these objects can not be used everyhwere in the world.
 
#4
The LibObjects are actually from the OBX50140.bgl

Whisplacer shows "unknown" close to the object.
On doubleclick it shows the properties.
It says GUID {1A18A415-C5AC-4FB0-949C-332CAB80181D}
and "Object not in Library"


In the OBXnnn.bgl there's the following section regarding this object:

<SceneryObject
lat="48.690047711134"
lon="9.19423565268517"
alt="0.0M"
altitudeIsAgl="TRUE"
pitch="0"
bank="0"
heading="0"
imageComplexity="NORMAL">
<LibraryObject
name="{1a18a415-c5ac-4fb0-949c-332cab80181d}"
scale="1.00"
/>
</SceneryObject>

and

<ModelData
sourceFile="1a18a415-c5ac-4fb0-949c-332cab80181d"
fileOffset="0"/>


Is it possible to add this object and others from the OBX to the Whisplacer DB?




Generally the preview function does work.
I have an object "air_beacontower01" in my scenery. That is being displayed correctly. Thumbnail also!



Michael
 
#5
The LibObjects are actually from the OBX50140.bgl

Whisplacer shows "unknown" close to the object.
On doubleclick it shows the properties.
It says GUID {1A18A415-C5AC-4FB0-949C-332CAB80181D}
and "Object not in Library"

In the OBXnnn.bgl there's the following section regarding this object:

<SceneryObject
lat="48.690047711134"
lon="9.19423565268517"
alt="0.0M"
altitudeIsAgl="TRUE"
pitch="0"
bank="0"
heading="0"
imageComplexity="NORMAL">
<LibraryObject
name="{1a18a415-c5ac-4fb0-949c-332cab80181d}"
scale="1.00"
/>
</SceneryObject>

and

<ModelData
sourceFile="1a18a415-c5ac-4fb0-949c-332cab80181d"
fileOffset="0"/>

Is it possible to add this object and others from the OBX to the Whisplacer DB?

Generally the preview function does work.
I have an object "air_beacontower01" in my scenery. That is being displayed correctly. Thumbnail also!

Michael
That object technically not a Library Object. It looks like a Library Object (same format, placement information etc.) but it was not authored by an artist and placed with the other artist authored models. Our (internal, non-SDK) export process allows for certain Generic Buildings that are either grouped together with other Generic Buildings or have irregular footprints to be programmatically extruded into models which are embedded within the bgl containing their placement information.

-Doug
 
Top