• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSX Please Help: SimConnect.dll Connection Problem

I am attempting to start writing my own SimConnect AddOns. I believe I have successfully installed both FSX SP1 and the FSX SDK SP1a on my MacBookPro running Windows XP SP3. (As I have very little room left on my internal hard drive, I installed these items to an external drive, known as E:.)

I am unable to get FSX to launch my AddOn successfully. This first AddOn, which is compiled with Visual C++ 2005, is merely a renaming of the "Open and Close" sample included in the SDK. The output to the console created by my use of the simconnect.ini file, shows that the three standard DLL's load correctly, yet neither my .exe AddOn, nor the .exe provided with the sample are able to load. Here is the console output:

0.00000 SimConnect version 10.0.61242.0

3.37134 Exe Launch Failed: GetLastError=0x000036B1 Path="..\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\Samples\Open and Close\Open and Close.exe" CommandLine=""

4.47072 Exe Launch Failed: GetLastError=0x000036B1 Path="E:\FSX\Software\AddOns\Hi\Debug\Hi.exe" CommandLine=""
4.61211 DLL Loaded: Path="..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll" Version="10.0.61355.0"
4.62120 DLL Loaded: Path="..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK\traffictoolbox.dll" Version="10.0.61355.0"
4.62903 DLL Loaded: Path="..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll" Version="10.0.61355.0"

Interestingly enough, the report from ADE9x Environment Checker seems to indicate that SimConnect isn't installed:

*************************************************************************************************
Date of Report: 2/23/2011 9:24:07 AM
Operating System: Microsoft Windows XP Professional
OS Service Pack: Service Pack 3 (3.0)
OS Version: 5.1.2600 (32 Bit)
OS Language: English (United States) => separator: '.'
Nodename: MIKETMACBOOKPRO
ADE installed: no
ADE Path: ADE not found
ADE Install Version: n/a
ADE File Version: n/a
ADE Info: n/a
FXS installed: yes
FSX Path: E:\Program Files\Microsoft Games\Microsoft Flight Simulator X\
FSX Version: 10.0.61355.0 (fsx-sp1.20070510-2038)
FSX Trailing '\' Error: False
FX9 installed: no
FS9 Path: n/a
FS9 Version: n/a
FS9 Trailing '\' Error: False
RTM Simconnect: no
SP1 Simconnect: no
SP2 Simconnect: no
FSX SDK installed: yes
FSX SDK Path: E:\Program Files\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\
FSX SDK Trailing '\' Error: False
BGLComp Version: 10.0.61355.0 (fsx-sp1.20070510-2038)
BGLComp >= SP1: yes
Shp2Vec found: yes
.NET 1.1 installed: yes
.NET 2.0 installed: yes
.NET 3.0 installed: yes
.NET 3.5 installed: yes
XML3 installed: yes
XML4 installed: yes
XML5 installed: yes
XML6 installed: yes
FSUIPC/FS9 installed: n/a
FSUIPC/FSX installed: not installed
Connected to FS9 ok: no
Connected to FSX ok: no
(Please Note: FSX was not running when I generated the report.)

So, maybe I don't have simConnect installed correctly?

My first attempt to correct this problem was to run the SimConnect.msi file I found in the SDK at E:\Program Files\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\lib, which is also the location that I directed Visual Studio 2005 to look for the .lib file. The manifest information embedded into my .exe follows:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
<dependency>
<dependentAssembly>
<assemblyIdentity type="win32" name="Microsoft.VC80.DebugCRT" version="8.0.50727.4053" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b"></assemblyIdentity>
</dependentAssembly>
</dependency>
<dependency>
<dependentAssembly>
<assemblyIdentity type="win32" name="Microsoft.FlightSimulator.SimConnect " version="10.0.61242.0" processorArchitecture="x86" publicKeyToken="67c7c14424d61b5b"></assemblyIdentity>
</dependentAssembly>
</dependency>
</assembly>

As I usually program in Visual C++ 6.0, the concepts of .NET assemblies and manifest files are still somewhat foreign to me; therefore, I could easily be making some simple mistake. I really hope this is the case.

I would really appreciate any help that anyone can provide, so i can get on with writing some real AddOns.

Thanks in advance.
(Note: due to a prior commitment, I will be offline until approximately 1:30PM PST today, 02/23/2011.)
 
Problem Solved! (or, at least, worked around)

The problem I was having was caused by a confluence of two conditions:

1. Installation of FSX and the SDK on a drive other than the system drive, and
2. Severe lack of space (< 500 MB) on the system drive.

I "solved" the problem by installing FSX and the SDK on a desktop machine that had > 130 GB of space on C:, its one and only drive.

So, I can develop on my MacBookPro, but I must test on this desktop machine.
 
Top