• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Please Select a Valid User Library File

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
I just started using ObjPlacer XML 0.81.0.28. When I attempt to select a new user library I get the subject error message "Please select a valid user library file". However, after clearing the error message, the selected library appears under Avalable objects/User library objects and I am able to place objects from the newly selected library. The library I am trying to access was originally developed for EZ Scenery.

Any thoughts?
Don
 
Hi Don,

You get this error when the XML loader failed to load the XML file. This could for example be because it is not a valid XML file or because some other application still has it open (and locked for use).
 
But, it is a valid file and, as noted earlier, it is added to the user library list as if the error had not occurred and I am able to place objects from it. It seems the error message should not have been given.

Today, when I tried to use ObjPlacer, a similar (but different) error message was issued five times immmediately upon loading the program - before I had a chance to attempt to add a user library. I recall today's error message was "Must select a valid user library" - or something quite similar.

Is it possible there's been some sort of file corruption?

Don
 
Hi Don,

That is weird. Can you maybe sent me your XML file? Then I can see if it also happens here at my PC.
 
Hi Don,

Thanks for emailing the file. I tried it here on my PC and I do indeed get the same error. But here it does not appear in the list afterwards (as I had expected, might be that that is something I have already fixed in my development version here).

After I had removed the spaces from your folder names, it seemed to work fine. So I think the XML parser does not like them for some reason. I'll try to figure out why.
 
Back
Top