Prepar3D v4.4 PBR materials

#21
That's right, I did not apply PBR textures, but I think that soon I will have questions about this.
I just make the runway, just like I always did. Everything is as usual, but this time the layer of dirt and bitumen is not displayed on the surface. If I do it separately, everything turns out and both layers are correctly displayed in the simulator.
 
Last edited:
#24
You should check on shadows in sim under Simulation Objects i think.
No, I'm sorry! I just did not compile correctly. Applied for FSX. So far the problem has remained even with negative Z-Bias.
I did what you said, but before, I always did a positive Z-Bias and everything was displayed correctly.
Desktop Screenshot 2018.12.15 - 20.31.10.62.png
 
Last edited:
#25
I want to explain a little what I want ...
The screen below shows my work for Prepar4.3
I want to get the same picture in Prepar4.4, but slightly change the look of concrete slabs
Prepar3D-Screenshot-2018_12.07---15_35_19.thumb.jpg.d825c249d923c79ade176b2c3dd6053e.jpg
Prepar3D-Screenshot-2018_12.07---15_39_57.thumb.jpg.8416dd43573dc52430cc2b2097313618.jpg
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#26
If this is not about PBR materials I wonder why you posted it in this thread and not in a new thread....

I made some changes to the GPW yesterday, so let me check if something has broken there. Positive or negative layers does not matter, the GPW will change the sign if needed (e.g. make them negative for P3D mdl files).
 
#27
If this is not about PBR materials I wonder why you posted it in this thread and not in a new thread....

I made some changes to the GPW yesterday, so let me check if something has broken there. Positive or negative layers does not matter, the GPW will change the sign if needed (e.g. make them negative for P3D mdl files).
Arno, I apologize for being off topic. I registered here yesterday and did not want to create a separate topic without studying the forum, but this takes a lot of time. I still do not know English well, I saw the name of the topic similar to the new "PBR" functionality and decided to write here.
 
#28
Well after some testing its just was a broken boot lol. im guessing my pc doing memes to me but sorry for all the mess here sorry arno its not your amazing program <3
 
#29
Arno I found a bug
All my textures are named in lowercase letters and all of my texture paths are lower case too.
How could a D drive be a small d (not as it should be at least).
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#30
Why would that be a bug? Windows is not case sensitive when it comes to paths.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#32
I made some changes to the GPW yesterday, so let me check if something has broken there. Positive or negative layers does not matter, the GPW will change the sign if needed (e.g. make them negative for P3D mdl files).
I have checked what goes on with the GPW, but I think it's a problem in the v4.4 XtoMDL. It seems that the ZBias value is not stored correctly for non-PBR materials. The code that worked before now results in a ZBias of 0 in the MDL file. The GPW then uses the default layer value of 8, which is what you see. I'll do some more checking to make sure it is not a bug on my side.
 
#33
I have checked what goes on with the GPW, but I think it's a problem in the v4.4 XtoMDL. It seems that the ZBias value is not stored correctly for non-PBR materials. The code that worked before now results in a ZBias of 0 in the MDL file. The GPW then uses the default layer value of 8, which is what you see. I'll do some more checking to make sure it is not a bug on my side.
Arno, hello! Thank you for your efforts! I look forward to the moment when everything works as it should. It's a pity if this error in XtoMDL takes your time! Yesterday I also tried 3DMAX to change the textures on the PBR and was surprised that the MCX works with the PBR material and sets the layers correctly.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#34
I guess for now if you don't use PBR materials just export at P3D v4 MDL in the GPW (instead of 4.4). The only reason to use the 4.4 exporter would be PBR anyway,
 
#35
I'll do it. But I only have version 4.3 of the earlier versions of the SDK ... I think it should work. We will wait for the bug fix in the SDK from the developers of this SDK.
 
#36
Hi @arno,

would it be possible to make the Diffuse Color also visible for P3D v44 PBR in the material settings. It has quite an impact, even when you have a diffuse texture, which seems to be something new.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#37
What do you mean with make it visible? The diffuse color should be in the editor already.
 
#38
What do you mean with make it visible? The diffuse color should be in the editor already.
But when I filter it to P3D PBR, it is gone... and I have to chose P3D again just to change this one value.. and also it is easy to forget. It is not a big deal and no deal breaker of course ;)
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#40
You were right, this attribute missed a tag. I have added it now and it will be in the next development release.
 
Top