Probelm with AG tree lib.

Regarding AG Tree lib.

I have planned to use this lib. in my project, in API format, but i discovered that above every treetop, a black line is "hanging" in thin air, and its spoils the otherwise exelent view.

Is there a way around this ??

Thanks in advance :wave:
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Jens Peter,

I got a bug report like this last weekend as well. It seems that the texture mapping shows a little big of the tree above it in the texture.

Does this happen all the time for you or only when you are far away? I am thinking it is a mipmapping problem, as I did not notice it when I tested the library myself.

Do the trees look normal for the rest or are they kind of blurry?
 
Hej Arno :)

Problem shows when close and looking up (parked under trees)
when you get close, they get a little blurry, but its not noticed froma distance (like the line)
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
OK, thanks, let me look into this. I might have to change the mapping of the texture a bit.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
I will make an update of the library. hopefully I have some time this week to work on it.
 
Help Help Help Pls.

:confused:

I still have SERIOUS problems on the Tree front. :( and are seeking the best poss. solution for it.

To have trees in, and in the near vicinity of my scenery, and not to heavy on the fps i was trying to use the Autogen SDK, but faced probs, even after reading the doc. and following the exsamples.

I selected first the world texture 047b2su3.bmp placed it in annotator, open it, added some tree areas, Saved, and placed the bmp it texturefolder (tried both main and scenery). I Also placed an area painted with the BMP in the scenery area with Airport for Windows. Unfortunately, after placing the BGL in the scenery file, and starting the FS, still no trees showed up :scratchch

So i really wonder why this dident work, and still, im left with problem having no trees in and around the two airport projects og mine. I could ,ofcourse, use some of the api's (but the AG file still not ready), but fear, since its great areas to modify, that it will kill FPS. Is there a better way, and what did i doo wrong.

If You Arno, or anyone can be a :wizard: on this, im very thankfull.

Best Rgds.

JP
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Jens Peter,

Autogen only works on mesh scenery. You can not have autogen scenery on polygons made with AFW for example. So you would have to use a program like SBuilder or Ground2k4 to place your mesh polygons.

Sorry about the update of the tree library, due to lack of time it has been delayed a bit.
 
Hello Arno

Well that gives me a clue of how to solve this problem, but it seemed to be an easy task acc. to the documentation in the FS-SDK pack, and the BMP used was from the Default Word Library.

By the way, how do your add trees, "the best way" is it by partly creating it via the SDK tool, and partly as sole objects (API's).


thanks for quick reply

Best Rgds
JP :)
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Jens Peter said:
By the way, how do your add trees, "the best way" is it by partly creating it via the SDK tool, and partly as sole objects (API's).
Not really sure what you are asking. But in general I would advice you to place them using XML code when possible. Only use the API macros when you really have to (when the rest of your project is still made in this way for example).
 
Top