• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Problem with animated object..

I have a "little" problem:

After having got my test jetways done with CAT, the airplane (!) disappears at some view angles or "zones" near the jetway.

I tested the location also without the jetway and no problem then with the aircraft..

I attached 2 pics to visualize. 1. one, A/C is visible, 2. bye bye Cessna! (also no shadow, so the complete plane is not drawn!) I only slewed about 4-5 meters into the "bermuda zone" ;)

Any ideas why??

Jeff
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Does this happen from all angles? So if you switch to the back of the aircraft, is it still gone?

Also, when does it appear again? How far forward must you go for that?
 
Well, haha, hmmm...

I think it was because of my *sorry* crappy coding... :rolleyes:
I tweaked the output of the CAT files a little, and there might be a small error...
(I replaced the IFIN 33B distance check with the IFIN_INSTANCED_PLANE...hmm, I'm sure it's this!)

I tested it with the raw CAT output and everything was ok again..my asm skills :eek:

Jeff
 
Top