Problem with Z bias.

jtanabodee

Resource contributor
Hi Arno,
I am trying to make ground poly with native P3D material. Things were going fine until I put the highest layer, the dirt mark over the runway. I could not see it in P3D. So, I went to check with Z bias.
I found that when I exported from 3dsmax to x file, MCX can read it correctly. But when I did the round world correction then export it as MDL, the Zbias turn to 0 all the time. I compiled it to bgl and loaded up to MCX and Zbias is still 0. Then I got back to MDL and change this to -1 in material and re-exported again. MCX gave me Zbias 0 the same. No mater how I change Zbias value, it always turn out to be 0.
I need the round world correction, so there is the only way to do through MCX and it keeps turning Zbias to 0 all the time. So the layer is a bit confusing now. Could you check on that, please?
Thanks
Tic
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

The round earth correction should not affect the zbias. So let me see if I can reproduce this.
 

jtanabodee

Resource contributor
I thought the program didn't write zbias back to the mdl like it should. Not the problem of round world correction. Even it opne x file up and save it as mdl, that happens too.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
That's weird. After loading the x file the zbias is correct in the material editor?
 

jtanabodee

Resource contributor
I got it Arno, it is from MCX. I have downloaded the new one and problem went away. Sorry for that.
I think it would be good if MCX has and update button and download automatically. Sometime I think the version I am using is the latest one b/c it just a few months ago. But it is not.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Glad to hear it is solved in the last version.

By default MCX checks for updates at startup and you will get a notification if a newer version is available. Clicking on the notification will bring you to the download page. As KAI31 said in the options it is specified if this check is done (by default it is on).
 
Top