QGIS difference tool (quirks?)

I've got a little issue with a quirk it appears in QGIS.

Ive imported my UK coastline (Ordnance Survey source, all multiple lines dissolved together, single parts joined as a multipart poly, as a shp layer, reprojected to WGS84)
I have also got a bounding polygon,(also shp layer, reprojected to WGS84)

I have tested the vector>geoprocessing>difference tool in QGIS with 3 very simple polygons so I know it can perform the task I want it to, which is to cut out from the bounding poly the coastline poly, so it essentially leaves me with a poly representing the sea around the UK. I intend then to use this in Scenproc to create my QMID11 hydropolys to be able to do accurate water masking around UK photoscenery.

However, when I use the same workflow that worled with the 3 simple polygons on the far more complex UK coastline poly, the output shp file is just the full bounding polygon again? :S

I've made sure the 2 layers have the same projection and are both shp layers, but I cant see now what might cause this not to work? Can anyone shed any additional light on why this more complex scenario isn't performing how I'd expect it to please?

Thanks Kev
 

Attachments

SOLVED: It was my stupidity. The difference tool works perfectly, the problem was I was trying to use a line layer with a polygon layer which was never going to work. A simple new layer containing the line transformed to polygon worked excellently :)
 
Top