FS2004 Real CAT Error

Hi All,

This time I have a genuine error that I cannot sort.

I've created some hanger doors, (Quite a few) which act in a corrugated fashion, one side work fine in GMAX and FS and exported & edited in CAT without problems, I then cloned those, flipped to act as the other side, exported fine and In CAT when I select the .ASM (not _0.asm) I get a "Run-Time Error '9' Subscript Out Of Range" error and the program closed, so, I assumed this was an issue with the cloning. So I painstakingly created the hanger doors again on the other side, not cloned, totally new boxes then applied the animation to each and exported, but the same error this time, If i select the hanger and the other doors all is ok with CAT, tick18_ is applied to all object names and none of these are duplicated.

Any ideas please? I've tried alot of different methods over the past few days, hence several threads, but this time I'm truly stuck :mad:

Any help is appreciated greatly.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Could you maybe send the ASM sources that crash and those that don't? It would be interesting to see where they differ. There must be a clue somewhere...
 
Hi Arno,

First off apologies for posting over the last few days topics that I've later found corrections for. I did some more testing today and found that CAT wasn't able to take a certain amount animated objects, so, I exported the two hanger door sides seperatly which has worked out OK.

Is this something that could be prevented for a future release of CAT, I believe you mentioned somewhere about not updating this program for a while, Its certianly a useful tool so thanks very much on that side.

Another question I did have, which saves opening a new thread, my hanger doors ofcourse work OK when you select the 112.00 on the NAV2 freq, the animation opens the doors as they should, when you switch off the freq this the doors simply jump back in to position (Becuase there is no animation) Is there a way, with CAT to reverse the animation after the frequency has been changed, or does this have to be animated?

Kind regards.
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

By default you should get the reverse animation. Do you only use a trigger or also an animation condition?
 
Not on the desktop at the moment but its only the first two screens I use, on the first I select the NAV2 to freq, nothing on the left then on the second screen I only use what is by default but use the NAV2 freq again, I can supply screenshots later on..
 
Hi Arno,

This is what my three animation screens look like, this doesn't play the reverse animation when you click off the NAV2 Freq;



Kind regards.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Don't use the animation condition, only use the trigger.

It is always a bad idea to use the same variable for both. The trigger is what starts and stops the animation. So that would be your frequency. The animation condition can be used to only allow triggering at a certain condition (for example only during the day). But they should never use the same variable.
 
Top