FS2004 Remove Shaddow & Crash

#1
Making a ground poly in Gmax, I am using an option script in the makemdl.txt to remove the crash box (crash=0). Then I run the mdl through mdlTweaker to remove the shaddow.
After this, the Library Creator fails to make the the lib.bgl with the following report:


Parsing document: library_creator_xml_temp_compile.xml

ERROR C2014: Failed to load model data in file: ..\mdl\Parkplatz.mdl
ERROR C2149: Failed to load model data!
ERROR C2340: Failed to finalize MODEL_DATA!
ERROR C2034: XML Parse Fatal Error (line, column, error)

ERROR: 10, 89, Mindestens ein Argument ist ungültig.

ERROR C2470: Unrecoverable error parsing XML!
ERROR C2006: Parse failed (0x80004005)
ERROR C2003: Failed to process file: library_creator_xml_temp_compile.xml

This error however, does not happen, when I export from gmax without the options script. It seams that MDLTweaker has a problem when the mdl file comes with some options hanging on it already and corrupts the file.
Is there a work around to this? :mad:

Could you maybe include a "Remove Crash" in this tool?:confused:
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

This tool is out of development, so there will not be any updates to it.

I always use the crash=0 in my makemdl.cfg file as well, so that should not be an issue. Also given the way MDLTweaker works I would not expect trouble in this case.

Can you maybe show me your MDL file? Maybe I can see anything from it.
 
#3
Yes, I include the original .mdl as it came out of gmax, which would work and the one that is tweaked, which will refuse to compile in library maker.
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#4
Hi,

It is weird, your tweaked MDL is smaller than the original one, while the remove shadow command adds more code.

What I see is that you have some "debugging" commands in your original file, I would advice you to export again from GMax but now with settings like optimize on in your makemdl.cfg (by default these should be on already btw). I think those commands are confusing MDLTweaker.
 
#5
Hi Arno,
I have compiled this example with the whole list of options, that's why the debugging might be on. But the problem also occurs, when I use only the crash=0 option.
I have to admit, this is a plane (groundpoly), wrongly made with FS2004 gamepack but it should still work, shouldn't it?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#6
Hi,

Yes, it should still work for a ground polygon. Does it also not work if you just compile with the default options (so no makemdl.cfg at all)?
 
#7
Once again,
I have exported now with this short list and it works (I had to "on" the optimize):

[Options]
Optimize=1
Crash=0
KeepErrorLog=1
Keep=1

Thanks for your help. Could you maybe have a look in the gmax forum about my other problem with the bluring textures?
 
Top