• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Replacement textures are pink from a distance

Messages
307
Country
unitedkingdom
I've just done RAF Valley and several people have mentioned that the airport is pink from distance away.

This is indeed the case. It's nearly all of the replacement textures doing it and I can't find a reason why. Restoring the stock textures solves it but of course it looks like crap.

Usually it's because someone's missing a texture in their install, but the same would happen up close and this only happens when you're several hundred metres or more away, and since several people have mentioned it I doubt they all have the same set up.

I thought it might be texture overlapping but that changes nothing.

It's not restricted to one texture, it's about 5-6 different ones, and in a small number of places the same texture is not doing it but is elsewhere.

I would guess it's some sort of LOD weirdness but I've no idea what the cause would be. Has anyone else had this and solved it?
 

Attachments

  • pinky.jpg
    pinky.jpg
    227.1 KB · Views: 116
  • pinky2.jpg
    pinky2.jpg
    90 KB · Views: 123

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,424
Country
us-wisconsin
When you say textures, exactly what type of textures? Is this aerial imagery? ProjectedMesh? Textured objects?
 
Messages
307
Country
unitedkingdom
Stock SDK ground textures applied to aprons. I should've worded that better. Returning to the default aprons cures it of course but that kind of defeats the point.

The only custom textures are a small number of runway numbers and runway ahead signs. Everything else is what they give you.
 
Last edited:
Messages
86
Country
canada
Stock SDK ground textures applied to aprons. I should've worded that better. Returning to the default aprons cures it of course but that kind of defeats the point.

The only custom textures are a small number of runway numbers and runway ahead signs. Everything else is what they give you.
Yup, my project as well from a certain level from far. My Materials and the default asphalts. ALL pink where my aprons are. Have you been able to possible correct? Asobo says they saw the issue have a guy on it but man its been 2 months. Still dont even know about SU6 fix target.

Just shooting in the dark asking around if any1 possible found a workaround.
 
Messages
307
Country
unitedkingdom
No.

When I started this thread no one else had reported this problem. Now it seems to be happening for more and more projects.

As you say Asobo have now acknowledged it as a problem. They've also said that about problems that have been there since the sim was launched.
 
Messages
111
Country
france
We had that problem with our OIIE release, we had no other choice than copying default apron textures into our airport materiallib. For example asobo TileConcrete06 material is duplicated as oiie-TileConcrete06, with corresponding textures (albedo and comp) found in Official folders re-exported as .png files, renamed with the oiie- prefix and then re-compiled into our materiallib.
 
Messages
86
Country
canada
We had that problem with our OIIE release, we had no other choice than copying default apron textures into our airport materiallib. For example asobo TileConcrete06 material is duplicated as oiie-TileConcrete06, with corresponding textures (albedo and comp) found in Official folders re-exported as .png files, renamed with the oiie- prefix and then re-compiled into our materiallib.
For me its both default and custom MaterilLibs so really doesnt matter. Any one possibly work around this?
 
Messages
111
Country
france
We had that problem with our OIIE release, we had no other choice than copying default apron textures into our airport materiallib. For example asobo TileConcrete06 material is duplicated as oiie-TileConcrete06, with corresponding textures (albedo and comp) found in Official folders re-exported as .png files, renamed with the oiie- prefix and then re-compiled into our materiallib.
To clarify:
- in dev mode airport editor, select the asobo/default materiel you're interested in. Look for the path and texture names in the material inspector.
- go find those textures (usually 1 albedo and 1 comp file) in the official folder, open them in an image editor (this in the most tricky part as you may have to first find a plugin to open .DDS format, I needed one for GIMP).
- export those textures in your material library source folder, in a compatible source format (I use .PNG), in the process give them a unique name (for example with the airport ICAO prefix).
- go back to MSFS, create your material as usual with the material inspector (don't forget the metal-roughness-AO -COMP- layer is there was one in the stock material). Again, name it uniquely, for example with an airport icao prefix. MSFS hates duplicate names scaterred in diffrent projects.

As the icing in the cake, in the process you can fix the bogus grass textures that don't come with 3D grass (set surface=GRASS instead of UNKNOWN). Browsing the official asobo material folders I even found textures not used in stock material libs, like those seamless patches of grass (GRASSGROUND05_ALBEDO.TIF).
 
Messages
111
Country
france
Sorry for asking, but... after creating your customs materials based upon Asobo ones, did you update all your aprons with your materials (or did you edit your xml files with your materials GUIDs) ?
 
Messages
23
Country
australia
That's ok, ask away, appreciate the help. Your method still presents the best option I can find to fix this problem.

I created a new material in the editor, using the texture I had converted to PNG and saved to my project/materials/textures folder. I used GRASS01_ALBEDO.TIF.DDS in this case. I have ensured that my material has a unique name and a new GUID.
I then removed one of the offending aprons (the grass apron covering the whole airport, the largest area of pink you can see) completely and recreated it, assigning my new material. I even created a whole new apron off airport to test in a area away from any other aprons and this field also turns pink.

This is a grass apron, with an opacity of 0. It's there to put grass where grass should be. There are other aprons with the problem but this is the one I am working on to try to solve the problem. I have experimented with many of the rendering options (changing the opacity, ground merging, material properties etc) and nothing seems to work.

1632347465168.png


1632347550734.png

1632347599607.png
 
Messages
307
Country
unitedkingdom
According to the sim update 6 notes pinkness from a distance is one of the fixes.

We shall see I guess.
 
Top