• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Resample tool fails

Hi,

I was so close to getting my photoreal scenery completed, but then the final step - converting all my work into an FSX compatible BGL file - does not go through.
Any time I try to run resample, I get the annoying error message popup that says "Terrain Resampler has stopped working. Windows is checking for a solution to the problem..." And we all know it never finds a solution.
I'm using FSX Photo Scenery Maker to do all the INF building and hard work for me. I figure maybe this is the problem though? I have tried taking the INF file directly and putting it into resample, but the error comes up again.

I have Vista Ultimate 64bit with FSX Accelleration (SP2), and FSXA SDK SP2.
I would appreciate any and all help, I have been looking forward to some good scenery for this area for ages! Heck, it never came out so I had to resort to doing it myself, but now it won't work!

Thanks for your time.


(Edit)
I thought this might help... a look at resample as it fails, there's a few 'questionable' lines of code here.
84677369ip3.jpg
 
Last edited:
A friend of mine just said that the resample tool won't compile properly if the image is over 1024x1024? And even then, FS does not support textures that are mapped at any higher resolution than that.

I'm not sure that effects me when it comes to mapping, but would this be a problem? The original BMP is 3200x2400 covering a fair portion of land, anyone who knows Gagetown Heliport knows what I mean (it also includes a lot of the OP area's in the vicinity).

Any help would be greatly appreciated! I really want to finish this project!

Thanks for your time! :)
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Rob,

No, the image can be much bigger than 1024x1024. I have compiled a photo scenery using sources that were a few GB each.

The crash itself does not give you that much information on where it goes wrong, as the command line output gives no error. It seems the process in Vista just quit.
 
Ah, I see. I appreciate your taking a look. I will try to restart my computer with no services running, getting rid of UAC and all that. Who knows what might be going wrong. I also have an old laptop running XP and FS9, I will try to transfer all the required files over and compile there. Hopefully it works then and XP doesn't kill the process. If it doesn't work, it must be that something is not functional with the SDK itself, I suppose.

I guess in the end, I may have to have someone else compile it for me? At a 25MB filesize, it shouldn't be too big a deal.

Thanks again! If you have any further ideas, I'd be glad to hear them.
 
Last edited:
Fascinating, I just got it to work.

It wasn't Vista's fault, because with the same INI, it didn't work under XP either.

I went and tried on of the example INI's and it worked just fine, so I rebuilt the INI for my photoreal scenery from scratch using one of theirs as a base, but obviously including the extra information required because its a BMP as opposted to a GeoTIFF.

It now works just fine, turns out the entry, Channel_LandWaterMask = '2.0' was at fault, after removing it, it all worked out just fine!

Thanks for all of the assistance, I hope this can at some point help others who may run into the same problem!
 
It's working flawlessly!
With a little bit more manual labour, it will be perfect and ready for departure!

Just wanted to say thanks again for the assistance!! A 'noob' like me could never get by without help from you tech's and dev's.

65371453rq0.png
 
There doesnt need to be single quotes around the '2.0': just use Channel_LandWaterMask = 2.0 (assuming of course that your land/water mask defined as the second source image)
 
Ah, ok. That would explain why removing the entry fixed it.
Not sure why that was even in there, I guess the application I used to do all of that for me put it in, even though it wasn't required.

Thanks for the tip!
 
yep - Just be aware that sometimes the examples in the SDK docs contain errors like this so copying and pasting text from there sometimes introduces these errors :confused:
 
Top