[Resolved] Dealing with model part conflicts (z-index?)


Resource contributor
Let me start by saying that I am very new to Blender and my basic understanding of how some things work is by no means close to an expert level. To date, I have done almost all my modeling work in Sketchup, which is obviously a night and day difference from Blender. However, I have recently started working with more complex models and needed something a little more robust to do texture mapping and AO with.

I have used Blender a handful of times to convert models I have purchased for use in the sim. However, the last model I have been working with has been giving me some issues that I cant seem to solve..

I downloaded a free to use campfire model and ended up remapping all the model parts to a single texture sheet. I also made some corrections to the orientation of the log textures, as the burnt ends were facing the wrong way. Easy enough..
The model looks great in both Blender and Model Converter X, however, when placed in the sim, something is clearly wrong. Sticks/Logs show above Rocks and Rocks even show above other Rocks..



I've delt with hierarchy issues before in Sketchup, which are fairly straight forward to deal with (But have also never looked like this issue), however, in Blender I am really struggling as it seems that the hierarchy tree works a lot different. It also looks like the tree got a little out of order on import. Could this be the root (pun intended) of my issue or could something else be messed up? As much as I have had to fix and redo on this model, I wouldn't be surprised..


Thanks to whoever may be able to help! I'm guessing that this is a fairly straight forward fix, but I just don't know how to correctly resolve it. :scratchch My best guess is I need to modify the hierarchy, but I haven't found an easy way to do that.
Last edited:


Resource contributor
Shot in the dark really but I'm assuming (maybe incorrectly) that the meshes are exported as separate objects? Have you tried combining the object to one mesh before your final export?

Failing that, ensure that your material settings for all 3 parts of the object are perfectly identical, and avoid using transparency. Use Default Opaque as that usually gets rid of drawing order issues.
If all 3 parts already use the same material settings then you can ignore that last suggestion.


Resource contributor
Following your advice, I double checked that all the materials were the same. All the model parts/mesh use the same default material, so I don't think there is an issue there. I also combined all the meshes before exporting it again. Unfortunately, there is still something wrong as the model is more jacked up than before. At least it looks somewhat different this time..


I also tried moving things around in the Outliner, trying to build a better hierarchy (if that even matters). It seemed to help a little, but much like the first post above, it's still not right. In fact, it's visual results are lodged somewhere between the first post and the image directly above..
Last edited:


Resource contributor
Sometimes all it takes is one month of trial and error and writing a forum post to figure out that the solution is so stupidly simple that you should have discovered it a month ago.
Z-Write Alpha = True is your friend when dealing with transparencies. Turned it on in MCX and boom.. a campfire that doesn't break the law of physics. (As much vegetation as I have made, you would have though this would have been muscle memory by now.)

I actually found the issue when I decided to make a snowy version of a model I had worked on and completed previously. Decided to put some icicles along the edge of the roof, only to make the same mistake and come up with the same results of the campfire. From there it was just a matter of working backwards and comparing settings with another working model, until I had the whole face palm moment.

One model completed an another fixed in the same day. I'd say that's progress. :rotfl: