P3D v4 RESOLVED: Ground Poly Layer: Changing arrangements don't show up/work

#1
Hi,
while arranging the ground poly layers in MCX/FSX work very well, I got massive problems to do the same in MCX/P3Dv4:

I created several transparent layers for my ground polygons (dirt, tracks etc.) arranged one above the other. When I changed their arrangements (changing their layer visible numbers) in MCX/FSX, I immediately see the changes in MCX (for example the track layer jump on top of the dirt layer). Converting it to FSX all those changings appears fine in the sim as well.
Doing the same steps in MCX/P3Dv4, nothing happens. No matter how I set the layer numbers, there is no alteration, neither in MCX nor in P3Dv4 after converting.

Is there a special change that happened between the FSX and P3Dv4 versions I missed?
 
#2
Just noticed: Using layer 16 as default ground polygon layer, the layer alteration works in MCX. That's strange, just because in P3Dv4 the layer should be negative, innit? I am confused...
 
#6
Thank you, Roby. That confirms the - in front of the positive layers after reopening the converted file. Will see how I can work with....
 
#7
Thank you guys, I finally got it to work. I reworked some of the layers from scratch (out of Gmax), because some contained unwelded Vertexes and some non flat surfaces.
I rearranged the layers alteration and now it does the work - I can arrange them now like my leisure :).
 
#8
Oh no - while everything looks fine so far, I noticed some weird appearance accidentally!



I didn't notice this before, just because it does not appear everywhere - only in this kind of view (spot outside/panning around) and only on the edges of the monitor!

- My layers are now native. all done with the MCX, version 1.4.0.0 0db39654 DEV 23.03.2019
- I set all layers negative, started with -1 for the grass base layer (first on the bottom)
- next higher layers all have a difference of 4, so next layer got -5 (grass overlay) etc. up to -64 for my runway markings
- I ticked (in the GPW)
"Project flat polygons on ground" using normal tolerance, value 0.990
"Filter out non-ground polygons"
to the upper left of the programme window.
"slice polygons" and "group polygons" at 500 m, therefor default to the mid right of the programme window.


Everything is converted into P3Dv4.

In ADE all airport ground altitudes are the same - Airport, Flatten and all land class. The flatten is much bigger than the ground poly radius...

What I've done so far:

1. Disabling one after the other layer to see if one of them is the culprit, but the issue continuous.
2. Change the altitude, first in ADE with lower Airport Ground Altitude (10 centimetres) - no success.
3. Change every layer by 10 centimetres upwards finally, no success.
4. Disabling all SODE xmls regarding RAF Brüggen just because of possible winter texture layer is the reason - no success...

As I said before, only during that kind of view and panning around this issue happens on the edges of the monitor. Panning or slewing the aircraft a little further, the layers get fine...And starts annoying at another place...

Can anybody please explain the different values of these points above, please?
 
#9
Hi,
Are you sure you put in the altitude of your airport in the GPW (=same altitude as in the airport properties of ADE)?
I am not sure about whether this has anything to do with it but I do not check 'group polygons 500m' (apparently not necessary for P3D).
 
#10
If you are using blender or 3ds max or whatever that is a modeling software be sure that the origin is the center (0,0,0) of each sub-object


Sent from my iPhone using Tapatalk
 
#11
Thank you both.
@Roby: Yes, did several trials with and without ticking - I think leaving "group polygons 500m" ticked seems a little less bleeding actually - in my case...

@Itay: I know this for designing bigger objects or models consist of several buildings with bigger range. There indeed you got the effect of suddenly disappearing objects, most time on the edge of the monitor. I got the same issues and solved it by adding four small planes underneath the ground, on each corner of the respective models.
So that may be the solution probably. But it's a little confusing because in FSX nothing like this happens and all ground polys appear perfectly. But now while using MCX for P3Dv4 these problems appear.
Furthermore, it will not be possible to centre each polygon just because all areas depend on the ground area image.
 
#12
You need to have a centered origin no to center polygon (I’m talking in blender) if you want you can drop me a message with the object and I will try to fix it for you


Sent from my iPhone using Tapatalk
 
#13
Ah, thank you, Itay. That clarifies the situation. Indeed I have the whole airfield centred, so that way my FSX ground polys work fine at least. I will try to fiddle around again with the "group polygons" section and maybe to add a LOD to my ground polys. But do GPW not add LODs automatically (section "visibility")?
 
#14
Would like to do some experiments with more large layer steps, but noticed when I use the negative values, my final upper limit is "-64". Can anybody confirm this or do I miss some settings? Would like to start at -4 instead of -1 just because I assume that too small layer value may cause my problem. But doing that large steps, I quickly run into layer limitation....
 
#15
Okay, after hard reworking of all my gp layers I have to say, it's done now :D!

- @Roby: I unchecked ALL my groundpolys "group polys 500m" like your suggestion.
- Then I equipped each layer with LOD 100 and 4 small planes at each corner with LOD 10. Hardest part of the rework.
- As opposed to my first experiments, all layers got the SAME airport ground level

Now the most important change:
- In "options", I set my "default layer" level to 16 - LIKE MY SETS IN FSX - and raise the upper layers with 2 values each, up to 50 for the top layer. All set positive, not negative. Arno, thank you for this tool, it sets the layer as in P3Dv4 needed to negative values automatically.

Done all steps as above, now my layers appear clear and without any issues at all.

I hope this will help users who get similar problems in future :wave:.

Thank you all for support!!!
 
Top