[RESOLVED]Problem creation "Material template editor" with the latest version MCX.

Hi,

With the version of 30-11-2018 (changelog) I can create a template
no problem using an existing material.

But with a 2019 version it does not work I have this error message:



I have not tried on another computer.

Thanks in advance
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Are you creating a new template or loading an existing one?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
OK, I'll try to reproduce it.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

I can't reproduce the problem here when I try to add new attributes to a template.

It is weird that the error mentions an old version of the DLL file. Are you sure you updated all files with the new version? Or are you loading a template saved with a much older version?
 
So for example you take any .BGL
You give him a setting ...

And if you want to save it, it puts this error message.


thanks to you ,
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
I'm still a bit confused. Are you applying the template to a material or making a new template?

And you still didn't answer the question if the template was made with an previous version.
 
hi,

-I'm exporting a .bgl blender output
-I do it in MCX
-I open material editor
-I do my settings
-I open material template editor
-I click on the triangle next to 'New'
-I select my material
-I rename the template
-I close (ERROR!)

Thanks
 
Last edited:
Hello,

I use the last developement version and ... I never find a "Material Template Editor" in menus or shortcuts.
Where can I find this new function ?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
And at which step from your list do you get the error?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
The material template editor is inside the material editor.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

The video shows a different error than you posted before. I'll see if I can reproduce this one
 
Hi,

The error in the video is because there is no folder "templates"

So it's ok, I'm going to redo a video with the previous problem.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
That folder should be there if you extract the zip. Are you sure you installed the tool correctly?
 
Yes of course I install it correctly,
the folder "Templates" I had isolated it for the video ...

I'm coming with the video :)
 
Top