• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

SAMM is unable to find aircraft folder

SAMM is unable to find the FSX aircraft folder, I'm running the Steam version of FSX; FSX;SE, when attempting to load an aircraft I get a pop-up message that SAMM2 is "Unable to locate aircraft folders", the directory tree does not list the "Program Files (x86)" folder which the root folder for the Steam version of FSX, can anyone offer me some direction on this issue?
 

gadgets

Resource contributor
You can expand the directory tree,

It appears that your FSX:SE is installed in some unusual fashion. Otherwise SAMM would find your aircraft.
 
Everything else seems to work using the same file path, so why can't SAMM. I've attached a copies of my directory tree, anyone see anything amiss?
 

Attachments

  • Directory tree - Copy.pdf
    312.6 KB · Views: 175

gadgets

Resource contributor
Not clear what you mane by "Everything else". But, SAMM (like most other applications that look for aircraft) looks for FSX.cfg (or FSX_SE.cfg if both FSX and FSX:SE are installed) in the AppData\Roaming folder. That's where the path to aircraft is specified.

It would seem that file is either missing or not where SAMM expects to find it. If it exists, locate it and save its path in AIFP.ini in the item "Path to FSX.cfg" (or "Path to FSX-SE.cfg if both are installed.)
 
Sorry, didn't mean to generalize, what I meant is that all of my other programs appear to work okay; AIFP3221, ADE175 and all other 3d party programs, the FSX configuration file is located under C:\Users\KRNMR\AppData\Roaming\Microsoft\FSX and the file path in AIFP is "Path to FSX.cfg=C:\Users\KRNMR\AppData\Roaming\Microsoft\FSX\FSX.cfg"
 

gadgets

Resource contributor
SAMM and AIFP use exactly the same code to locate aircraft. What do you have selected under Aircraft: From" on the Main Panel
 
SAMM and AIFP use exactly the same code to locate aircraft. What do you have selected under Aircraft: From" on the Main Panel

Thanks for hanging in there with me gadgets, there are only four tabs active on SAMM's main page, all other tabs are grayed out, here is an image of the main panel
1579396770137.png


If I select "FSX" or "Other" I get the following pop-up
1579396898159.png

when I click OK it launches the following panel which when expanded should Illustrate the file path to my sim objects folder,
1579397111468.png

as you can see the tree doesn't expand beyond MSFS and doesn't appear to "see" the "Program Files (x86) folder and consequently I can't get to the Sim Objects folder, I've used SAAM previously with both FS9 and FSX, prior to my changing over to the Steam version, the following illustrates the file path to the Simobjects folder

1579398193082.png
 

gadgets

Resource contributor
Something is definitely wrong but, at the moment I have no idea what. I have just had two other reports of a similar situation in AIFP. But, the version of SAMM you are using is almost a year old and in AIFP, this appears to be a recent and sudden problem. I'm suspicious a recent Windows update has changed something that AIFP and SAMM depend upon. (As I noted in an earlier post, SAMM and AIFP use the same code to locate aircraft.) You noted earlier you weren't experiencing such problems with ADE. I don't believe ADE attempts to locate aircraft.

I note the very limited information in the directory tree. Clearly, that's not all of your C: drive - which brings me back to a windows update.

But, I am not experiencing any such problems - and I have all the windows updates for North America.

I'll keep you updated as things (hopefully) progress.

Which they already have. Just now I tried again and with FSX and FSX:SE only, I get the same error message, I didn't get that message as late as this afternoon.

It's late here. I'll investigate further tomorrow. This definitely is not due to a recent change in software, The latest development release of SAMM is nearly 6 months old
 
Yeehaw!

1579467192108.png


As you can see I can now expand the tree to access all of my aircraft folders. In retrospect I'm now wondering if I could possibly not have told SAMM where to find my FSX.cfg file when I first started SAMM, I feel stupid but please accept my apologies and thanks for resolving the issue. Now off to make some static aircraft!
 
Okay, I may have spoken too soon. I closed SAMM to do a little housekeeping and now it's back to not showing any thing below my MSFS folder. The only thing that comes to mind is that when SAMM was first launched after applying the update, there appeared a dialogue box stating that SAMM couldn't find the FS9.cfg file, I provided the file path to the FSX.cfg file and every thing appeared to be okay as I indicated, but now..??????
 
I'm pretty confident it said FS9.cfg, unfortunately I can't get SAMM to generate that dialogue page again because I didn't save a copy of the previous iteration.
 

gadgets

Resource contributor
I'm going to withdraw that release until I get a chance to investigate further - probably tomorrow.
 

gadgets

Resource contributor
SAMM was able to find your FSX.cfg file at least once (with the updated file) and, when it did so, your directory tree expanded normally. The earlier inablility to access the aircraft folders was my problem and now fixed The problem was introduced a year ago. It only occurred when FSX or FSX:SE was selected and would only affect users who acquired SAMM (or at least didn't run SAMM initially until) after the problem was introduced.

When you successfully ran SAMM after the update, SAMM would have saved the path to the FSX.cfg file in its .ini file. I doubt that the earlier message said "FS9", since SAMM would only look for the FS9.cfg file if you had FS9 installed. From the earlier screenshot, it appears you do not. But, if the error message said "FSX.cfg" that that would help explain your short directory tree since it would suggest Windows is having difficulty reading your C: Drive. (SAMM uses standard Windows function to create the directory tree. That code hasn't changed in years.)

Please open SAMM.ini and check for a line that reads "Path to FSX.cfg= path on your system".
 
Top