P3D v4 Samui Airport upgrading to P3Dv4

Yes, support P5 is definitely necessary, at the moment almost all the main problems have been fixed, and no matter how you want to stay on the old P4, you still have to upgrade to P5 :wizard:
 

jtanabodee

Resource contributor
Honestly I have no time to read how v5 different from v4.5 . I cannot keep up with those updates. It needs time to do.
 
Top