• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

SBUILDERX 315 - Anyone using something

gfxpilot

Resource contributor
Hi guys been attempting to get the above to work with my FSX steam on a new win 10 machine (not bragging - old one fell over)

Its been 3 months and nothing! - Ive gone through just about every post I can find and done all the suggestions plus of course a multiple amount of uninstall reinstall, pray, start again.

Is anyone using an alternative that can give background images in the same manner (ish) as SBX
 
Last edited:

gfxpilot

Resource contributor
It can then it cant find FSUIPC, random responses when called (fsx running)

It cannot down load / access any satellite images no matter which option you use (with and without fsx running

When requesting a move to when you enter egff co ords - I end up in the Bristol Chanel, English channel, Normandy with FSX running and AC on the runway
Latitude: 51° 23' 28.79" N
Longitude: -3° 20' 21.60" W

of course nothing at all when FSX not running

All FSX paths are right - none showing red in the settings.

when I selelect from the help menu to get a map from the web I get
<% Lat = Request.QueryString("Lat") Lon = Request.QueryString("Lon") Zoom = Request.QueryString("Zoom") T = Request.QueryString("T") if Lat = "" then Response.Redirect "gmaps.htm" end if if Lon = "" then Response.Redirect "gmaps.htm" end if if Zoom = "" then Zoom = 15 end if if T = "" then T = 0 end if %>

Then the remaining text boxes are there (
Click and drag the marker to get the Latitude and Longitude of a location. You can also fill the boxes and press "GoTo" to center the map on that location.You can also "Show" or "Hide" LOD13 grid lines.

The center of the map is:

The boundaries of the map are:

You can check for the availability of this map on different providers.

Press "Window" to open the map in a new window and with a different size.
1600 x 1200 3200 x 2400
is ther in "

When I use File - Addmap from ARC GIS I get a map of somewhere of I think USA (FSX running - AC still at EGFF) OR I get "Cannot Get An Image at Zoom -8!" < thats started to day




When it did work and got the CARDIFF (EGFF) area up as a background in the image there was one small issue -----------------------------all foliage and no airport!!



INSTALLING I tried going through the versions and updating each install untill I got to 315. - none of that worked at all..... I found the one that was a complete 315 and used that and that my friends is where we are today!
 

rhumbaflappy

Moderator
Staff member
Resource contributor
You can use this link to get the full SBuilderXv315.zip
It's a zip file that has a folder containing what you need to get started. It is 64-bit, so it doesn't run on a 32-bit system. It doesn't get installed, just unzip to the location of choice and go. You may need to look at the SBuilderX.exe file to unblock it and to give it Administrator privileges. I place my folder in D:\Programs\FSX Tools\ Do not place it in anything like Program Files or Program Files (x86). It's not installed, so just unzip and use. You'll need to set the paths.

For FSX:SE you need a current FSUIPC v4 installed into FSX:SE... FSUIPCv4.975
Unzip it on your desktop and doubleclick on the Install FSUIPC4.exe Again, you may need to unblock it and add Administrator privileges.

SBuilderX will work without FSUIPC or with it.

Users can always use the SDK tools directly, and there are other programs that use the SDK tools.
 

gfxpilot

Resource contributor
Thanks Dick. The 315 zip is indeed the one on the machine now. However, I'll look into the fsuipc v4 and fire it all up again

I'll. get back to you
 

gfxpilot

Resource contributor
Downloaded again the 325 zip , uninstalled old and reinstalled, added the FSUIPC4 again. - tested - FSX live and AC on runway at egff.

selected to fly AC to: - that could not communicate with FSUIPC4
Otped to show Ac - same message.


tried all map setting options - nothing and SBUILDERx doesn't recognise where I am
 
Hello:

IIUC SBuilderX is working OK. and FSUIPC is not. :scratchch


You may need to remove FSUIPC and reinstall it.

The web page for updated modules shows the current version to be used with FSX_SE:

https://forum.simflight.com/topic/80977-updated-modules/


Note: the above updates may require an existing full install of FSUIPC to work; get those here:

http://www.fsuipc.com/



FSUIPC FAQ's are here:

https://forum.simflight.com/forum/141-faq/


Links on troubleshooting FSUIPC with SBuilderX:

https://www.google.com/search?biw=9...&ved=0ahUKEwjjk62xyN7pAhUZCs0KHQgVDusQ4dUDCAs


GaryGB
 
Last edited:

gfxpilot

Resource contributor
Thank Gary.

uninstalled FSUIPC - looked at latest in the moduls link - V6 is the latest and for PSD

Have the same client as stipulated in the same forum. Have the version for 64byte FSX win 10.

Tried uninstall., cleared registry , rebooted and started again.

Loaded FSX(at egff) loaded
started up SBX.
Opted to move AC to cariff despite being there - result - ended up in the Mediterranean as the lat -long adjusted itself from cardiff but to the Med sea.

Attempted fly to option but that had the text boxes pre populated and the lat/long were editable.


Attempted to load a map from ArcGis........................... O dear. get a map of sorts, told system to "Go to position" endter
Latitude: 51° 23' 28.79" N
Longitude: -3° 20' 21.60" W


AC ends up near Green Land on the map view but is in reality sitting on RW 30 at EGFF.



Gave up. White flag went up.
 
I've noticed some warnings about the FSUIPC connection if I try "fly aircraft here" first. If I do "show aircraft" before I do anything else that requires the FSUIPC connection to the sim then it all seems to work OK ("fly aircraft here", "get point from aircraft", etc). I'm still running Win7 and I'm using P3D v4.5 (hence FSUIPC 5) so maybe this is completely irrelevant. I've just noticed you usually attempt "fly aircraft here" first so I wanted to relate my experience. Try "show aircraft" first and see if that changes anything.
 

gfxpilot

Resource contributor
@ Dick - Im running 64 byte so installed and uninstalled the 32byte version just to see if itll do something (anything) of course nil

@JR - tried your steps - yes I get the show aircraft but nowhere so red cross hairs appear on a white background (at least something is showing) but when I use the goto position and end teh lat long for any uk based airports I end up either in the north sea or somewhere obscure

here in the pic Ive set the go to for Gatwick UK EGKK. FSX has the AC on the runway at the airport as well and Ive entered the lat/long in . this is the result when I look at the map and show aircraft.
 

Attachments

I see you're at zoom level 1 and from my experience things get wonky with the map whenever the zoom level goes below 6. You'll find most everything you need to do in SBX you'll need to do between zoom levels 14 and 24 so there's never really any need to be zoomed out that far anyway. Start the sim and go to the location you're interested in, do show aircraft, get the red crosshair against the white background, check the zoom in the lower left corner and roll your mousewheel until it's about 14, then do "show background". Also open your SBuilderX.ini (root SBuilderX folder, same folder as SBuilderX.exe) and set DecimalDegrees=True in the [Main] section. While you're at it set LonIniCenter=-.1903 LatIniCenter= 51.1481 (for Gatwick) and SBX will start up at that location initially.
 

gfxpilot

Resource contributor
UPDATE: took it all off for XZY time, cleaned out the registry for equal time. , reinstalled again; went back and triple checked the google tile dll downloaded the latest version and over wrote existing TWICE. loaded fsx, fired up SBX running as admin. changed the tile server to that appropriate. started the process of getting the background using go to position. Happy days this time I have the satellite of EGFF .... however, no airport anywhere in the graphic (cant explain that one ) went to show AC . blank screen and red cross hair. F1'd again ..........................................Happy day!!!!!! there was Cardiff AP with Cross hair qulaity at zoom 20 was more than acceptable for photoreal AND the AC was only 4 metres off the centre line on the threshold.

I have no Idea what the heck I did right/wrong but suddenly SBX and my system seem to want to play together this far. Now Ill test the functionality

Thanks to all who had input (Especially Dick/Gary for the advice) Also JR. will keep that note ready for next steps
 
Top