• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Sdk Animation - Where'd My Wheels Go ??

OhGreatObeeKanobee,
Running Win 7 64bit Pro - 3dsmax 2009 32bit - Prepar3d v1.4 - 4747 - Sdk 4747 - Every thing is installed - and seems to be working - Exports into the Sim - Textures - Animations - Attach Points - Vc and Gauges - all show up in the Sim - However My Animations seem to have learned a New Trick ! - Propeller Animations Work fine - Shut the Engine down - Prop Stops - Start the Engine Up - Little Puff of Smoke - and We're Running - Wheel Animations - Kick the Brakes - Goose the Throttle - the Wheels Start to Turn Normally - Then at 12 Knots - They Disappear ?? - I have tried Reinstalling the Sdk - I have Tried Not Using the Animation Manager - By Giving the Wheel Objects the Name of the Animation - The Controls and Doors Seem to Animate Normally - Just the Wheels - any Ideas - Please ?? Johnman :confused:
 
Hey Paul,
Each Wheel has Two Objects - Still and Blurred.
Could it Be that the Blurred Animation is Not Showing up ?? - Because The Wheels Do Start to Turn - But Never Get Real Fast ??

A Shot from My Heirarchy
Heirarchy.JPG


Johnman
 

n4gix

Resource contributor
Johnman, did you remember to tag both _still and _blurred with the Attachpoint tool's Visibility? Select one of the _blurred wheel objects, right click and check to make certain that the visibility condition has been added correctly.
 
Hey Bill,
I think We're getting Somewhere - I did what I think You told Me to - With the Attach Point Tool - and now the Nose Wheel is Normal - The Left Wheel is NOT there - and the Rt Wheel does what it was doing - This May be Progress in a Reverse Direction ? - I'll fiddle with it more Later - Reread the SDK - and come back with what I come up with - could You expand a bit on the use of the Attach Point Tool - Much Appreciated - Johnman :cool:
 

n4gix

Resource contributor
Okay, this is how you check objects to see what tags have been applied via the Attachpoint Tool. Select object in GMax/Max, right click on the screen and open the Object Properties. Click the "User Defined" tab and read the XML script. Note that this shows <Visibility name="l_tire_blurred_key"> defined:

mcQSo.jpg


Here is how the tag is applied with the Attachpoint Tool. With the object selected, open the Attach Point Tool, click on Visibility. Use the drop list to select the correct visibility tag, then click on the "Attach to selected geometry" button:
mcRa1.jpg
 
Last edited:
Bingo Bill - You Nailed It -"We're RollinDownTheRunway - Thanks Again - Thought You Guys Might Like to What Its All About - My Symphony 160 - On The Runway in Ketchican AK - Need to Finnish Up Animations - Light'er Up - Then - On To The Paint Shop - YEEEE HAAAAAW - Johnman :):cool:

Symphony 160 1a.JPG
 
Top